2 Replies Latest reply on Dec 11, 2003 3:05 AM by Wouter Zoons

    Struts TilesPlugin broken in jboss 3.2.x ?

    Jens Viebig Newbie

      Has anyone successfully deployed a struts application with TilesPlugin in jboss 3.2.x (3.2.3) . I'm getting

      java.lang.AbstractMethodError: org.apache.struts.tiles.TilesPlugin.init(Lorg/apache/struts/action/ActionServlet;Lorg/apache/struts/config/ApplicationConfig;)

      errors when i try to deploy my app which was running fine with jboss 3.0.8.
      The Struts 1.1 struts-example.war crashes with the same Error Message !!

      Anyone has the same problem or has the example running ?

        • 1. Re: Struts TilesPlugin broken in jboss 3.2.x ?
          Jens Viebig Newbie

          I narrowed it a bit.
          Seems to be a bug in jboss i think (classloder,classpath issue).
          This error occurs when you have more than one war using struts.
          It depends on the sequence you deploy your wars.
          I have one war (a) using Struts 1.1b and a war (b) using Struts 1.1
          when I deploy (b) first and after that (a) everything is working fine.
          when I deploy (a) first and (b) second i get that error !
          I think jboss is putting WEB-INF/lib somewhere in the global classpath so things get broken !
          So it seems not to be a struts-related problem

          • 2.
            Wouter Zoons Newbie

            yep, it works for me, never tried it with mulitple struts WARs though, but should also work

            mixing libs of different version in the same container is not recommended :-)

            classloader troubles are the most fun, aren't they :-/

            good luck
            cheers
            Wouter.