2 Replies Latest reply on Jan 30, 2004 9:43 AM by yibing Li

    pase error -- type "filter" must be declared

    yibing Li Newbie

       

      "yli" wrote:
      While I am trying to deploy my EAR file, EJBs are deployed successfully but while deploying the war file, the following errors are shown up:

      004-01-29 11:52:38,514 INFO [org.jboss.web.tomcat.tc4.EmbeddedTomcatService] deploy, ctxPath=, warUrl=file:/D:/jboss-3.2.3/server/default/tmp/deploy/tmp48827GNX-CPM-20040129.ear-contents/GNX-CPMWeb.war/
      2004-01-29 11:52:39,342 ERROR [org.apache.commons.digester.Digester] Parse Error at line 11 column 13: Element type "filter" must be declared.
      org.xml.sax.SAXParseException: Element type "filter" must be declared.
      org.xml.sax.SAXParseException org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseException(org.apache.xerces.xni.parser.XMLParseException)
      ErrorHandlerWrapper.java:232
      void org.apache.xerces.util.ErrorHandlerWrapper.error(java.lang.String, java.lang.String, org.apache.xerces.xni.parser.XMLParseException)
      ErrorHandlerWrapper.java:173
      void org.apache.xerces.impl.XMLErrorReporter.reportError(org.apache.xerces.xni.XMLLocator, java.lang.String, java.lang.String, java.lang.Object[], short)

      This seems related to xml parser or servlet.jar. I know filter is only compatible with servlet 2.3. But I am sure JBoss3.2.3 is using tomcat 4.1 and is servlet 2.3 compatible.

      Do I need to do anything to use filter in my web application?

      Please help.

      Thanks,

      Yibing


        • 1. Re: pase error -- type
          Jonathan Leech Newbie

           

          "jleech" wrote:
          just a guess but check your doctype in web.xml, perhaps its not the servlet 2.3 one. e.g. <!DOCTYPE web-app PUBLIC
          "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
          "http://java.sun.com/dtd/web-app_2_3.dtd">


          • 2. Re: pase error -- type
            yibing Li Newbie

            Thanks a lot. That was the problem and after I fixed that and re-order my web.xml, I still got the following two errors:

            2004-01-30 09:43:25,266 ERROR [org.apache.commons.digester.Digester] Parse Error at line 8 column 7: Element type "urn" must be declared.
            org.xml.sax.SAXParseException: Element type "urn" must be declared.
            org.xml.sax.SAXParseException org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseException(org.apache.xerces.xni.parser.XMLParseException)
            ErrorHandlerWrapper.java:232

            and

            2004-01-30 09:43:25,391 ERROR [org.apache.commons.digester.Digester] Parse Error at line 23 column 10: The content of element type "taglib" must match "(tlibversion,jspversion?,shortname,uri?,info?,tag+)".
            org.xml.sax.SAXParseException: The content of element type "taglib" must match "(tlibversion,jspversion?,shortname,uri?,info?,tag+)".
            org.xml.sax.SAXParseException org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseException(org.apache.xerces.xni.parser.XMLParseException)
            ErrorHandlerWrapper.java:232
            void org.apache.xerces.util.ErrorHandlerWrapper.error(java.lang.String, java.lang.String, org.apache.xerces.xni.parser.XMLParseException)
            ErrorHandlerWrapper.java:173

            it looks like this is related to taglibs. in my web.xml:


            <taglib-uri>/tags/struts-bean</taglib-uri>
            <taglib-location>/WEB-INF/struts-bean.tld</taglib-location>


            Do you see anything wrong?

            Thanks a lot.

            Yibing