2 Replies Latest reply on Feb 26, 2004 7:06 AM by Brad Balmer

    Struts/JBoss error

    jimmywu Newbie

      Hi guys,

      i got this error when i tried to run my upload.jsp on my JBoss 3.2.3:

      Generated servlet error:
      [javac] Compiling 1 source file
      [javac] C:\jboss\server\default\work\MainEngine\localhost\coleman\upload_jsp.java:9: package org.apache.struts.webapp.upload does not exist
      [javac] import org.apache.struts.webapp.upload.UploadForm;
      [javac] ^
      [javac] C:\jboss\server\default\work\MainEngine\localhost\coleman\upload_jsp.java:100: cannot resolve symbol
      [javac] symbol : variable UploadForm
      [javac] location: class org.apache.jsp.upload_jsp
      [javac] Iterator iterator = errors.get(UploadForm.ERROR_PROPERTY_MAX_LENGTH_EXCEEDED);
      [javac] ^
      [javac] Note: C:\jboss\server\default\work\MainEngine\localhost\coleman\upload_jsp.java uses or overrides a deprecated API.
      [javac] Note: Recompile with -deprecation for details.
      [javac] 2 errors

      i have put my .jar files in my WEB-INF/lib and my struts.*.tld files into WEB-INF folder

      here's my web.xml:

      ---


      <servlet-name>action</servlet-name>
      <servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
      <init-param>
      <param-name>config</param-name>
      <param-value>/WEB-INF/struts-config.xml</param-value>
      </init-param>
      <init-param>
      <param-name>debug</param-name>
      <param-value>2</param-value>
      </init-param>
      <init-param>
      <param-name>detail</param-name>
      <param-value>2</param-value>
      </init-param>
      <init-param>
      <param-name>application</param-name>
      <param-value>org.apache.struts.webapp.upload.UploadResources</param-value>
      </init-param>
      <load-on-startup>1</load-on-startup>


      ---

      and my struts-config.xml:

      ---

      <struts-config>

      <form-beans>
      <form-bean name="uploadForm"
      type="org.apache.struts.webapp.upload.UploadForm"/>
      </form-beans>

      <action-mappings>
      <!-- Upload Action -->




      </action-mappings>

      ---

      can anyone help me out with the problem?