1 Reply Latest reply on Mar 12, 2004 7:22 AM by draganj

    Problems with windows-1250 character set!

    draganj Newbie

      Hi,

      I have been using setup jboss version 3.0.8 so I can use windows-1250 encoding. Database is mysql.
      So configuration is following:
      in run.bat I added following two properties:
      -Ddefault.client.encoding=windows-1250 -DISO_8859_1=Cp1250
      and
      in mysql-service.xml file used jdbc:mysql://localhost:3306/mydb?useUnicode=true&characterEncoding=windows-1250 connection url.
      in .jsp files used charset and pageEncoding.
      And this configuration works with 3.0.8.

      Now I am trying to use version 3.2.3 but upper configuration does not work.

      Any ideas as what am I doing wrong?

      Thanks,
      Dragan

        • 1. Re: Problems with windows-1250 character set!
          draganj Newbie

          Hi again,

          I have solved the problem.
          Solution is to add a filter to your web application (in web.xml):
          --------------------------------------------------------

          <filter-name>Set Character Encoding</filter-name>
          <filter-class>filters.SetCharacterEncodingFilter</filter-class>
          <init-param>
          <param-name>encoding</param-name>
          <param-value>Windows-1250</param-value>
          </init-param>

          <filter-mapping>
          <filter-name>Set Character Encoding</filter-name>
          <servlet-name>action</servlet-name>
          </filter-mapping>
          --------------------------------------------------------

          Bye,
          Dragan