0 Replies Latest reply on Mar 24, 2004 4:24 PM by swang30

    JDK 1.5 and Jasper?

    swang30 Newbie

      System: Linux Fedora
      JDK: 1.5 (see below)
      JBoss Version: 4.0 DR 2

      I started JBoss, got hit with the error that JDMK was included in JDK 1.5, unjarred rt.jar and removed all references to the management packages. Restarted the server and everything was peachy.

      Now I go to the JMX console, and the logs come up with a Jasper error:
      org.apache.jasper.JasperException: Unable to compile class for JSP
      at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:478)

      with the root cause as:
      java.lang.IllegalArgumentException: name
      at org.jboss.util.property.PropertyMap.get(PropertyMap.java:132)

      Anybody know what is going on or have an workaround? I'm just starting a new project and would like to use JDK 1.5, workarounds while various issues get resolved are fine for me, as long as I know to back it out when the real thing comes...

      Jeff