0 Replies Latest reply on Oct 12, 2004 5:09 AM by Daniel Williams

    FileNotFoundException

    Daniel Williams Newbie

      Hi,

      I am using Applet / Servlet HTTP communication. All very standard stuff. My webapp deployed and ran fine under JBOSS 2.4.6 (although the jboss admin who got it working initially has long since gone and I can't remember what he did to make it work!) and deploys and starts up fine under JBOSS 3.2.3 but when I try to actually use the webapp, the trouble starts.

      The Applet tries to make a call to the Servlet and gets the below shown FileNotFoundException that looks as follows:
      java.io.FileNotFoundException:
      http://10.1.2.3:8080/my_app_context/servlet/MyServlet?action=225&ONE_OF_MY_CUSTOM_HTTP_PARAMS=SOME_APP_SPECIFIC_VALUE
      at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:689)
      at ... (Where the StackTrace eventually shows the root cause to be the function I'm using to call the Servlet via HTTP with a HTTP 'GET'.

      It seems the JBOSS sets up the /my_app_context context OK and serves up JSPs, my client application JAR file and static / HTML content fine but cannot get at the server-side part of the webapp (i.e. Servlets and associated helper / utility classes).

      I want the app. to run unsecured i.e. no authentication necessary. No security is declared in the web.xml.

      Some system info that may help with the diagnosis is:

      I'm running the following:

      1. JBOSS 3.2.3 / Tomcat 4.1.x bundle

      2. JDK 1.4.1-b21

      3. Win2k Professional

      I have a jboss-web.xml deployed with the app. which simply reads:

      <?xml version="1.0" encoding="UTF-8"?>
      <jboss-web>
       <context-root>/my_app_context</context-root>
      </jboss-web>


      The JBOSS access logs show 404s whenenver I try to access any servlets (whether directly with a browser for testing or with Applet code).

      Hope someone can help!

      Dan