0 Replies Latest reply on Feb 21, 2005 11:20 AM by Beatriz Campo

    Servlet. Missing application web.xml ...

    Beatriz Campo Newbie

      hello!

      I'm trying to deploy mi 'HelloWorld' servlet on jboss. When I put the .war file into server/default/deploy folder I get the following error:

      INFO [ContextConfig] Missing application web.xml, using defaults only StandardEngine [jboss.web].StandardHost[localhost].StandardContext[/MyWar]

      This is weird, cause I have the web.xml file included in the MyWar.war file. I've searched in the web and I read it's because I must save web.xml as plain text or maybe because in the servlet there are opened descriptors.

      I had a look at the entire jboss folder and I found some folders with the name of my war file, once undeployed it!
      The url is then, localhost:8080/MyWar/HelloWorld/HelloWorld but I get the '404 Not Found' error.
      What's going on? Any help will be appreciated.

      Here is the web.xml file:



      <?xml version="1.0" encoding="UTF-8"?>
      <!DOCTYPE web-app
       PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
       "http://java.sun.com/dtd/web-app_2_3.dtd">
      
      <web-app>
       <servlet>
       <servlet-name>HelloWorld</servlet-name>
       <servlet-class>HelloWorld</servlet-class>
       </servlet>
       <servlet-mapping>
       <servlet-name>HelloWorld</servlet-name>
       <url-pattern>/HelloWorld</url-pattern>
       </servlet-mapping>
      </web-app>
      

      Thanks in advance