1 Reply Latest reply on Nov 28, 2005 10:43 PM by Oleg Konovalov

    Redirection problem (Apache->JBoss) ?

    Oleg Konovalov Newbie

      Hi,

      We have powerful Solaris server which hosts 2 sets of Apache 2.0.48 -> JBoss
      3.07 with Tomcat 4.1.18
      using mod_jk2 2.0.2, running a bunch of web applications.
      They are configured to run independently (2 server names, 2 virtual servers,
      different ports, etc.)
      Used to run without a single glitch for about 1/2 year.

      Yesterday we had a power failure, so the server crashed.
      After that we rebooted it, it automatically started Apache, we manually
      started JBoss.
      One set was totally restored (no problems whatsoever), but another one has a
      problem:
      - if you try to run any of the applications, getting error 404;
      - if you try to go to the main page: http://myserver1.com , you are getting
      index.jsp (Tomcat's main page
      with the cat);
      - but if you try to use port 8080 (http://myserver1.com:8080 ), getting main
      page and all the apps just fine.
      Even tried to kill the second instance of java process for JBoss/Tomcat -
      same exact picture on server1
      (ghost tomcat? - no catalina or tomcat proccesses running)
      Actually, is Tomcat a java process ?(seem to have tomcat.exe in bin
      directoty)

      I interpreted it as a failure of something in the Apache-Tomcat-JBoss
      bridge.
      So I tried to do the following:
      - reboot server - same problem;
      - reinstalled Apache, copied all config files and modules (imcl. ) from old
      instance of Apache to a new one - same;
      - after that restarted JBoss - same.

      Nobody touched any config files.

      I forgot to mention that if I shutdown the second instance of JBoss/Tomcat,
      on the second instance of Apache http://myserver2.com I am getting error "Internal Server Error" (that is a normal behavior, right ?),
      but on the first instance of Apache http://myserver1.com I still get the
      same Tomcat admin page with the cat (index.jsp)
      although no java processes are running.
      If I go to any application on either server, getting error 404 "Resource not
      available"

      Can you explain how can I get that Tomcat's webapps/admin/index.jsp page when JBoss/Tomcat is down,
      is that mod_jk2 doing somehow ?

      Maybe something with inability to resolve localhost
      (somewhere in config - we had that problem before) ?

      Could you please suggest what might be wrong and how to fix it ?



      Please help !


      TIA,
      Oleg.

        • 1. Re: Redirection problem (Apache->JBoss) ?
          Oleg Konovalov Newbie

          To give you an update:
          1) I am not sure why (don't think anything was modified),
          but something has changed: when you do: http://myserver1.com,
          it no longer shows the admin page of Tomcat,
          but shows page with something "If you see this page you have a problem
          with configuration" (Apache sample page).

          2) We replaced all "localhost" with the IP address of that virtual server
          (it has 2 network cards, 2 IP addresses, etc.) - same result

          3) We copied the working version of JBoss and modified its configuration
          (mostly port numbers) to be as it was on that instance originally - same result.

          4) we looked at Apache's error_log file, here is a fragment of typical
          output (within msecs):

          [error] uriEnv.init() map to invalid worker /jmx-console/* ajp13:mopppgctxad1:8009
          [error] uriEnv.init() map to invalid worker /web-console/* ajp13:mopppgctxad1:8009
          [error] uriEnv.init() map to invalid worker /* ajp13:mopppgctxad1:8009
          [error] mod_jk child init 1 0
          [error] jk2_init() Can't find child 25476 in scoreboard
          [error] uriEnv.init() map to invalid worker /jmx-console/* ajp13:mopppgctxad1:8009
          [error] uriEnv.init() map to invalid worker /web-console/* ajp13:mopppgctxad1:8009
          [error] uriEnv.init() map to invalid worker /jmx-console/* ajp13:mopppgctxad1:8009
          [error] uriEnv.init() map to invalid worker /* ajp13:mopppgctxad1:8009
          [error] uriEnv.init() map to invalid worker /web-console/* ajp13:mopppgctxad1:8009
          [error] uriEnv.init() map to invalid worker /* ajp13:mopppgctxad1:8009
          [error] uriEnv.init() map to invalid worker /jmx-console/* ajp13:mopppgctxad1:8009
          [error] uriEnv.init() map to invalid worker /web-console/* ajp13:mopppgctxad1:8009
          [notice] Apache/2.0.48 (Unix) mod_jk2/2.0.2 configured -- resuming normal operations
          [error] uriEnv.init() map to invalid worker /* ajp13:mopppgctxad1:8009
          [error] mod_jk child init 1 -2


          Please advise.

          Thank you in advance,
          Oleg.