2 Replies Latest reply on Dec 29, 2005 5:24 AM by Scott Stark

    JSP worked in JBoss 3.2.x but not working on JBoss 4.0.3SP1

    Iván Párraga García Newbie

      Hi,

      I had some web-apps with servlets and JSPs perfectly working on JBoss 3.2.6 and 3.2.7. I decided to update to the last JBoss version (I needed better support for webservices) and I've found some strange problems.

      Most web-apps deployed without problems, but some JSPs (not all of them) in some web-apps don't work any more. The problem is that the server is not able to compile the generated java servlet (but it GENERATES the .jara!) and returns an exception like this:

      ---

      org.apache.jasper.JasperException: Unable to compile class for JSP

      An error occurred at line: 43 in the jsp file: /CalculationOptions.jsp
      Generated servlet error:
      Syntax error on token ";", = expected

      org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:84)
      org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:328)
      org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:397)
      org.apache.jasper.compiler.Compiler.compile(Compiler.java:288)

      ---

      and the part of the code of the JSP is this:

      <%! String ODAPerformAnalysis; %>
      <%! String ODAPerformAnalysisChecked; %>
      <%! String ODACorrectPDB; %>
      <%! String ODACorrectPDBChecked; %>
      <%! String ODACorrectPDBDisabled; %>

      <%
      ODAPerformAnalysis = (String)session.getAttribute("ODAPerformAnalysis");

      if(ODAPerformAnalysis==null)
      ODAPerformAnalysis="false";

      if(ODAPerformAnalysis.equalsIgnoreCase("false"))
      {
      ODAPerformAnalysisChecked = "";
      ODACorrectPDBDisabled = "true";
      }
      ../..
      %>

      Any idea?

      Iván