0 Replies Latest reply on May 22, 2006 8:08 AM by Rikko Verrijzer

    The difference between Tomcat 5.5.16 and JBoss(Tomcat5.5.16)

    Rikko Verrijzer Newbie


      I encountered a weird situation while trying to debug a portlet. The bug I tried to debug is not really that important, but if you want to know: Somehow when I press the save button in this portlet it didn't save.

      In my efforts to get this portlet debugged, I tried to view this portlet as a servlet. which is perfectly legal because I'm using Orbeons OPS, which has all the functionality programmed as a servlet.
      When I did this, I noticed that the servlet was running perfectly, and without this dreaded bug, in Tomcat 5.5.16. However when I tried to do the same a bit later in JBoss 4.0.4.RC2(Tomcat5.5.16), and also as a servlet, the bug was still present.
      Although I did something that should have given identical results, it returned something different.
      This is something I have trouble to understand, because everything is identical. Both use the same Tomcat version for their servlets, both had the same war file, and yet this bug did occur in JBoss and it did not in Tomcat.

      Now what I want to know is, what is causing this difference? what is JBoss doing to Tomcat which causes it to behave differently? I already checked the classloader of JBoss, because I know they used to be different there, but not anymore! now JBoss also uses the Tomcat classloader.
      I don't think the reason can be in the servlet itself because it was the same war file (no recompile or anything).

      Anyone got any ideas what can be causing this difference??

      I used the following versions:
      Orbeon OPS 20061018 /20061019
      Tomcat 5.5.16
      JBoss 4.0.4.RC2 (Tomcat 5.5.16)