0 Replies Latest reply on Aug 17, 2006 5:48 AM by Muhammad Asif Mahmood

    Jetty 4.2.19 on JBoss 3.2.1

    Muhammad Asif Mahmood Newbie

      Dear All,

      Currently I'm ussing Jetty 4.2.9 on JBoss 3.2.1. I've just come to know that this version of jetty contains a vulnerability that can allow an attacker to cause a denial of service condition. I wish to upgrade jetty to version 4.2.19. I downloaded jboss-3.2.1-jetty-4.2.19.sar and replaced the contents of deploy\jbossweb-jetty.sar folder with the contents of sar file. JBoss throws the exception that it cannot fine the web.xml file of web-console.war. It seems that 4.2.19 is not compatible with JBoss 3.2.1.

      Do you know the solution how to upgrade jetty?
      Am I doing something wrong or missing any step?

      One more thing, I couldn't find any resource which tells what version of jboss is compatible with what version of jetty. Is there any matrix which describes the compatibility of jetty and jboss versions?

      Thanks for your help in advance.

      Regards,
      -Asif