1 Reply Latest reply on Nov 14, 2006 1:55 PM by Thunder Williams

    jboss_init_suse.sh ssl problem

    Thunder Williams Newbie

      I have a complicated configuration. I have a java server application that is invoked by jboss and jboss serves clients with an SSL connector and an HTTP connector.

      The jboss application server responds perfectly when I run my startserver.sh script to run my app server as a foreground process. It responds to http:8080, https:8077, and https:8443

      When I use the jboss_init_suse.sh as an RC script to run the startserver.sh as a background process then the HTTP still works but then the server no longer responds on the SSL ports. It only responds on the http port.

      I am unable to guess what the problem might be. I also tried running the init script as root and it had no effect.

        • 1. Re: jboss_init_suse.sh ssl problem
          Thunder Williams Newbie

          Some additional info:

          using JDK 1.5.0_07 on SUSE 10.1

          when it is running in the background using the rc script, when i point internet explorer (windows version) at the SSL port it will just give me a blank page and the little ssl icon in the bottom right corner of the browser says: "This type of document does not have a security certificate."