0 Replies Latest reply on Apr 23, 2007 5:39 PM by chun ji

    Does jboss4.0.5GA  suppoer Jasper Compiler ?

    chun ji Newbie

      I am new to Jboss 4.0.5.GA, and wand to do a precompiling of JSP files in one of my web application.

      I am using JBOSS 4.0.5GA, Ant 1.6.5 and JDK 1.6 On LINUX box.

      The directory tree of the application is as follows:

      /project
       |--- > /web_pre-comp/pages/jsp ( it contains all the jsp files )
       |----> /web_pre-comp/WEB-INF ( it contains the web.xml file.)
       |----> /web_pre-comp/WEB-INF/tld ( it contains the tld files)
       |----> /web_pre-comp/WEB-INF/src ( it coutains the generated src file from jsp )
       |---->/web_pre-comp/WEB-INF/classes ( it contains the compiled classes once the jsp java files are generated. )
       |----> build.xml ( the ant script )


      And here is part of my build.xml file:
      "
      <project>
       ...
       <target name="pro.jsp.generate" depens="init">
       <java classname="org.apache.jasper.JspC" fork="yes">
       <classpath refid="tomcat.jsp.classpath"/>
       <arg line=" -d "/>
       <arg value="${jsp.generated.src.dir}"/>
       <arg line="-p"/>
       <arg value="${jsp.package.name}"/>
       <arg line="-webapp"/>
       <arg value="${jsp.src.dir}"/>
       </java>
       </target>
       ...
      </project>
      "

      And web.xml file:
      "...

      <taglib>
       <taglib-uri>http://www.prounlimited.com/wandappconfig.tld</taglib-uri>
       <taglib-location>/WEB-INF/tld/wandappconfig.tld</taglib-location>
       </taglib>
      "

      But when I run the ant script, I still get such error messages:
      "...

      [java] org.apache.jasper.JasperException: The absolute uri: http://www.prounlimited.com/wandappconfig.tld cannot be resolved in either web.xml or the jar files deployed with this application
      "

      Any comments ?


      Thanks a lot for the help




      Charlie