0 Replies Latest reply on May 29, 2007 8:04 AM by Ignacio de Cordoba

    NoClassDefFoundError in a expanded war from its own /lib/ ja

    Ignacio de Cordoba Novice

      Hi there,
      i am trying tu configure class loading in JBoss 4.0.5
      I have an .ear file with <loader-repository-config> and java2ParentDelegation=true
      I need to access classes in this .ear from my war application, deployed in a war dir (I need to work on it, can't package it in the .ear file)
      I've tried to reference to the same class loader with jboss-web.xml and tried all combinations of java2ParentDelegation and java2ClassLoadingCompliance flags with no success. The most I've been able to achieve is loding the classes in the ear' jars but classes in /WEB-INF/lib/ jars are then invisible to the webapp (¿?). How can I make the webapp mix both class loaders?
      Thanks for any help. Please don't point me to those 2 documents about JBoss class loading. I've been reading them for years and, as happens with many JBoss users, can't get a clear picture of all this flags. ¿Any alternative documents about class loading configuration in web apps in JBoss? Thanks for any help until some one writes that pending Web Class Loading WiKi.