1 Reply Latest reply on Aug 16, 2007 5:34 PM by James Van Zandweghe

    Base is null error

    sandip patil Newbie

      Hi All,

      I am getting Base is null error when I try to login to my application.

      javax.servlet.ServletException: Base is null: loginFormBean
      javax.faces.webapp.FacesServlet.service(FacesServlet.java:202)
      org.apache.myfaces.component.html.util.ExtensionsFilter.doFilter(ExtensionsFilter.java:122)


      root cause

      javax.faces.el.PropertyNotFoundException: Base is null: loginFormBean
      org.apache.myfaces.el.ValueBindingImpl.resolveToBaseAndProperty(ValueBindingImpl.java:455)
      org.apache.myfaces.el.ValueBindingImpl.getType(ValueBindingImpl.java:169)
      com.sun.faces.renderkit.html_basic.HtmlBasicInputRenderer.getConvertedValue(HtmlBasicInputRenderer.java:111)
      javax.faces.component.UIInput.getConvertedValue(UIInput.java:713)
      javax.faces.component.UIInput.validate(UIInput.java:638)
      javax.faces.component.UIInput.executeValidate(UIInput.java:849)
      javax.faces.component.UIInput.processValidators(UIInput.java:412)
      javax.faces.component.UIForm.processValidators(UIForm.java:170)
      javax.faces.component.UIComponentBase.processValidators(UIComponentBase.java:912)
      javax.faces.component.UIViewRoot.processValidators(UIViewRoot.java:342)
      org.apache.myfaces.lifecycle.LifecycleImpl.processValidations(LifecycleImpl.java:240)
      org.apache.myfaces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:76)
      javax.faces.webapp.FacesServlet.service(FacesServlet.java:197)
      org.apache.myfaces.component.html.util.ExtensionsFilter.doFilter(ExtensionsFilter.java:122)



      I am using apache-tomcat-5.5.17,JDK 1.5,Exadel.

      I have jsf-api.jar,jsf-impl.jar also I have myfaces-api.jar,myfaces-impl.jar.
      On various forums I read that put one jar out of these two(i.e Sun's or myfaces)
      But when I created my project first time with above jar files it worked fine for me.

      But when I try to create another project its giving me above error.

      Can anybody tell me why its giving me above error.I almost searched on google but no luck.

      I am deploying my project through ant command to external tomcat.

      1) I tried to create project by opening eclipse in clean mode to remove cache but still no success.

      Thanks
      Sandip