2 Replies Latest reply on Jun 28, 2007 10:34 PM by Gareth Anderson

    Problems with an old version of Jboss and mod_jk with Apache

    Gareth Anderson Newbie

      Hi guys,

      I was asked to upgrade the version of mod_jk used by our apache 2.0.59 to a newer version so I went ahead and grabbed the newest version from the Apache connectors website http://tomcat.apache.org/connectors-doc/

      However since upgrading to the newer version of mod_jk, compiled from source on a Linux box with both versions 1.2.21 and 1.2.23, I cannot get it working.

      What the browser shows is a "200 Ok Response" and that the server is not working.

      I found the Jboss version to be:
      Release ID: JBoss [WonderLand] 3.2.1 (build: CVSTag=JBoss_3_2_1 date=200310021350)

      In the apache mod_jk logs I get:

      [Thu Jun 28 16:22:04 2007] [5301:26336] [error] ajp_connection_tcp_get_message::jk_ajp_common.c (1005): wrong message size 10268 8192 from 127.0.0.1:8009
      [Thu Jun 28 16:22:04 2007] [5301:26336] [error] ajp_get_reply::jk_ajp_common.c (1606): (workertest) Tomcat is down or network problems. Part of the response h
      as already been sent to the client
      [Thu Jun 28 16:22:05 2007] [5301:26336] [error] ajp_connection_tcp_get_message::jk_ajp_common.c (1005): wrong message size 10260 8192 from 127.0.0.1:8009
      [Thu Jun 28 16:22:05 2007] [5301:26336] [error] ajp_get_reply::jk_ajp_common.c (1606): (workertest) Tomcat is down or network problems. Part of the response h
      as already been sent to the client
      [Thu Jun 28 16:22:05 2007] [5301:26336] [error] ajp_service::jk_ajp_common.c (1942): (workertest) Connecting to tomcat failed. Tomcat is probably not started
      or is listening on the wrong port


      I found these old posts:
      http://osdir.com/ml/java.jetty.support/2003-01/msg00133.html

      Which are around a similar time and *may* be related.

      Any ideas whats wrong here?
      Do I need to upgrade Jboss/jetty before I attempt to upgrade mod_jk?

      Currently we have an older version of mod_jk running but there is no information on which version it is, even in debug mode the version information does not get printed.

      Does this look like a problem with a very old version of Jboss? Or am I doing something wrong with mod_jk.

      Also does anyone know an appropriate forum for mod_jk, I cannot find one.

      Regards,
      Gareth

      Regards,
      Gareth