0 Replies Latest reply on Nov 7, 2007 11:28 AM by David Welford-Costelloe

    Apache2 Jboss Portal

    David Welford-Costelloe Newbie

      Hi,
      I am wondering if someone could help me figur out how to ensure that the Portal not the Jboss is loaded when using remote url;

      My setup is using Ubuntu Linux, Apache2.4
      My URL is set for http;//www.welford-costelloe.com by default the JBoss Managemen screen is loaded. If I pass the url as http;//www.welford-costelloe.com/portal I do load the portal page. I would rather the portal load with the main url:

      Confoguration:
      httpd.conf
      =======
      LoadModule jk_module /usr/lib/apache2/modules/mod_jk.so

      JkWorkersFile /etc/apache2/workers.properties
      JkShmFile /var/log/httpd/mod_jk.shm
      JkLogFile /usr/local/apache2/logs/mod_jk.log
      JkLogLevel info
      JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "

      workers.properties
      ============
      worker.list=worker1
      worker.worker1.type=ajp13
      worker.worker1.host=localhost
      worker.worker1.port=8009


      Default
      =====

      NameVirtualHost *:80
      <VirtualHost *:80>
      ServerAdmin webmaster@localhost
      ServerName welford-costelloe.com
      DocumentRoot /www/www.welford-costelloe.com/portal

      Options FollowSymLinks
      AllowOverride None

      <Directory /www/www.welford-costelloe.com/>
      Options Indexes FollowSymLinks MultiViews
      AllowOverride None
      Order allow,deny
      allow from all
      # This directive allows us to have apache2's default start page
      # in /apache2-default/, but still have / go to the right place
      #RedirectMatch ^/$ /apache2-default/

      ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
      <Directory "/usr/lib/cgi-bin">
      AllowOverride None
      Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
      Order allow,deny
      Allow from all


      ServerSignature On
      LogLevel warn

      ErrorLog /var/log/apache2/www.welford-costelloe.com-error_log
      TransferLog logs/www.welford-costelloe.com-access_log

      JkMount /* worker1

      #
      # allow from all
      #
      Alias /doc/ "/usr/share/doc/"
      <Directory "/usr/share/doc/">
      Options Indexes MultiViews FollowSymLinks
      AllowOverride None
      Order deny,allow
      Deny from all
      Allow from 127.0.0.0/255.0.0.0 ::1/128
      allow from all



      Thanks
      David...........