0 Replies Latest reply on Feb 11, 2009 7:11 AM by Richter Belmont

    JBossWeb / Apache integration problem on AIX

    Richter Belmont Newbie

      Hi all,

      I was hoping one of great minds here can shed some light on the problem we are having.

      As the topic subject suggest, the problem we are facing revolves around integration of apache web server 2.2.9 and JBoss AS 4.2.2 GA running on IBM AIX 5.3.

      To explain the background, those two boxes have been talking happily to each other on AJP port using mod_jk for several months now and configuring this was the least of our problem. What is causing me a huge headache is that there is a known JBoss Web bug which manifests itself from this integration.

      I've done my homework and found following JIRA entry below:

      JBossWeb leaves hung ajp connections with mod_jk
      https://jira.jboss.org/jira/browse/JBWEB-82

      The symptom of the exact same problem we are facing is outline in this entry and from what I can make out there are two potential workarounds to the problem. That is:
      1. Use JBoss Native
      2. Download JBoss AS source, patch certain code and rebuild

      From the two options available above, I would like to dismiss the second one due to various reasons and hence why I have pursued option of using JBoss native.
      Boy, what a nightmare it has been. I've downloaded and tested out JBoss Native for Windows platform and it has Worked straight way. AIX? Nope, life aint that easy.

      If you go to following URL:
      http://www.jboss.org/jbossweb/downloads/jboss-native/

      You will find JBoss Native port available for every platform (including HP-UX!!) known to man kind, except AIX. I have to admit, I was expecting this match. It's not my first time I needed a software component and only platform not available for download is AIX.

      So I've downloaded source code and decided to build it by myself. I had a lot of problems building it due to missing libraries, incompatible command, etc, etc but long story short I have managed to build it at the end.

      I could have been a happy man if only this stuff actually worked. So I've modified our JBoss instance start up script to include path to newly built JBoss Native libraries to be part of $LIBPATH environment variable ($LD_LIBRARY_PATH for most of other platforms) and restarted JBoss.

      And I got a log message saying:

      18:40:07 INFO [org.apache.catalina.core.AprLifecycleListener] The Apache Tomcat Native library which allows optimal performance in production
      environments was not found on the java.library.path: /usr/java5_64/jre/bin:/usr/java5_64/jre/bin:/usr/java5_64/jre/bin/classic:/usr/java5_64/
      jre/bin:.:/usr/local/jboss-native/lib:/usr/lib

      I've tried all kind of things but it just does not work...

      So please can someone suggest an idea?
      Or can someone at least confirm whether JBoss Native actually work in AIX environment or not? There is virtually no documentation on it so it's hard to make out what is the deal is.
      Is it one of those thing JBoss native can "theoretically" work on AIX platform but nobody tested it or someone here has a success story?