3 Replies Latest reply on Dec 14, 2001 3:17 PM by larry bartz

    Help on JAAS-JETTY

    santhosh Newbie

      Hi can anyone help on how to setup jaas for jetty jboss.

        • 1. Re: Help on JAAS-JETTY
          Jules Gosnell Novice

          If you are using JBoss3, pull down the latest from cvs and if it doesn't work, let me know (Jules_Gosnell@yahoo.com).

          If you are using JBoss2, the security stuff was never really finished, I have refactored it for JBoss3, and now that I understand it may backport it into a JBoss-2.4.4/Jetty-3.1.5 release if/when time permits, but I'd rather people just moved over to JBoss3, then my time doesn't get split between two releases.

          Jules


          • 2. Re: Help on JAAS-JETTY
            larry bartz Newbie

            Jules,

            In your message of Dec 5, you mentioned that you
            might backport your refactored security stuff
            to Boss-2.4.4.

            Do the recent beta releases of 2.4.4 include the
            refactored code?

            If I jump to JBoss3 (to attain functional JAAS support
            for Jetty), how much of the documentation I just bought
            through Flashline will be wrong, nonsense, misleading,
            or not applicable?

            • 3. Re: Help on JAAS-JETTY
              larry bartz Newbie

              Julian Gosnell wrote:
              >
              > I haven't backported it yet.
              >
              > I haven't seen the flashline doc !


              It is written to JBoss 2.4.4.


              >
              > As far as Jetty's concerned - all you need to know is what the 2.3 servlet
              > spec says and how to deploy stuff - copy into jboss/deploy.
              >
              > The rest of Jboss has probably changed substantially - but then I've no
              > idea how much you paid for the doc !


              Only ten bucks; a bargain!


              >
              > You are going to have to make the leap to JBoss3 sooner or later - why not
              > experiment with it sooner ?


              I'm new to JBoss and J2EE, so I prefer the comfort of working with
              documented software, at least for now as I'm getting my feet wet.
              I'm really not into "experimenting". I'm implementing, with a deadline.

              What about the JBoss-2.4.4_Tomcat-3.2.3-beta and JBoss-2.4.4_Tomcat-4.0.1-beta
              packages? Do the JBoss/Tomcat packages exhibit the same JAAS deficiencies
              as the JBoss-2.4.4/Jetty packages?


              >
              > Give me some feedback on the JAAS stuff in Jetty4/JBoss3 and if it doesn't
              > work, I will fix it. If it does work, you may not need to go back to 2.x.
              >
              > If you find stuff that you really need from 2.4 lacking in 3.0 let the list
              > know.
              >
              > Bear in mind that JBoss3/Jetty4 is Servlet2.3/JSP1.2 and JBoss2.x/Jetty3 is
              > Servlet2.2/JSP1.1.
              >
              > If you are going to play with 3.0 - check out a recent CVS version - the
              > last released build I saw was very out of date.


              I'm behind a very tight firewall, so CVS is somewhat problematic. A fresh
              build would be an incentive.


              >
              > Jules
              >
              > P.S.
              >
              > I'd like to do the backport - but I have to hold down a fulltime job - I
              > haven't even enough time to do the work I want to on JBoss3 - let alone
              > 2.4....


              Do what you must. Your efforts are appreciated.