4 Replies Latest reply on Dec 9, 2002 3:21 AM by Marcel Offermans

    Thawte SSL Certificate

    John Childress Newbie

      Hello,

      I have been attempting to use JBoss 2.4.4 / Tomcat 4.0.1 with a ssl cert issued by Thawte. I have been able to setup and use a cert that I issued myself, but no luck with the cert from Thawte.

      The specific error I receive when JBoss starts up is:

      javax.net.ssl.SSLException: No available certificate corresponds to the SSL cipher suites which are enabled.

      I'm using Red Hat Linux 7.2, and have tried both the 1.3.1 and 1.4 (rc1) jdks. Both jdks result in the same error.

      I am confident that the cert is ok, as I have imported it successfully and can run keytool -list -v and view the cert info.

      My config seems ok also, in jboss.jcml, as when I switch the keystore to one with my self gen cert, JBoss "works". As soon as I use the keystore with the Thawte cert, I receive the error.

      I just wanted to ask for help, before I dropped $50 for another cert :-(

      Thanks for any help,

      John

      I have tried both