2 Replies Latest reply on Jun 25, 2007 8:29 AM by Peter Aschenbrenner

    commandButton in rendered Panel does not work

    Peter Aschenbrenner Newbie

      Hi,

      can anyone help me with this issue ?

      When I render an outputPanel the form inside does not work properly:

      ...
      <a4j:outputPanel id="panel">
       <a4j:form>
       <h:panelGroup rendered="#{show}">
       <rich:dataTable id="editTable" cellpadding="0" cellspacing="0" width="400" border="0" var="aList" value="#{List}">
       <rich:columnGroup>
       <rich:column>
       <h:outputText value="Type" />
       </rich:column>
       <rich:column>
       <h:outputText value="#{aList.type}" />
       </rich:column>
       </rich:columnGroup>
       <rich:columnGroup>
       <rich:column>
       <h:outputText value="time" />
       </rich:column>
       <rich:column>
       <h:inputText value="#{aList.time}" />
       </rich:column>
       </rich:columnGroup>
       <rich:columnGroup>
       <rich:column colspan="2">
       <a4j:commandButton action="#{evenBeant.saveAction}" value="speichern" reRender="panel"/>
       </rich:column>
       </rich:columnGroup>
       </rich:dataTable>
       </h:panelGroup>
       </a4j:form>
      </a4j:outputPanel>
      ...
      


      The outputPanel get rendered by another action but the commandButton does not perform the saveAction. But when I move the commandButton outside the panelGroup, the action works.

      I'm using the latest snapshot of a4j (1.1.1) and richfaces (3.0.1) ...

      Any ideas?

      I'm thankful for any advice ... petrovic