1 Reply Latest reply on May 3, 2002 3:15 AM by J. Wolfgang Kaltz

    Basic Auth w/ JBoss+Catalina+Apache

    Alex Newbie

      Hi,

      I'm using JBoss-2.4.4_Tomcat-4.0.1 integrated w/ Apache apache_1.3.24 using org.apache.ajp.tomcat4.Ajp13Connector.

      For apps with no security, everything seems to work fine. (http://localhost/jboss/) My problem is when I try to access an app that has Basic Authentication, I get the login screen, but it won't accept my password.

      I know I have the Authentication set up correctly as I can go directly to the Catalina port(http://localhost:8080/quaestor/login.jsp) and the Authorization works fine.

      My hunch is that Apache can't figure out how/where to get the authorization.

      Here is what server.log looks like:
      [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][4] An incoming request is being assigned
      [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][4] The incoming request has been awaited
      [INFO,Default] [Ajp13] setSocket()
      [INFO,Default] [Ajp13] receiveNextRequest()
      [INFO,Default] [Ajp13] receive()
      [INFO,Default] [Ajp13] receive: len = 404
      [INFO,Default] [Ajp13] receive: total read = 404
      [INFO,Default] [Ajp13] decodeRequest()
      [INFO,EmbeddedCatalinaServiceSX] Ajp13Processor[8009][4] invoking...
      [INFO,Default] [Ajp13] sendHeaders()
      [INFO,Default] [Ajp13] status is: 401(Unauthorized)
      [INFO,Default] [Ajp13] send()
      [INFO,Default] [Ajp13] sending msg, len = 65
      [INFO,Default] [Ajp13] doWrite(byte[], 0, 611)
      [INFO,Default] [Ajp13] send()
      [INFO,Default] [Ajp13] sending msg, len = 619
      [INFO,Default] [Ajp13] finish()
      [INFO,Default] [Ajp13] send()
      [INFO,Default] [Ajp13] sending msg, len = 6
      [INFO,Default] [Ajp13] recycle()
      [INFO,Default] [Ajp13] receiveNextRequest()
      [INFO,Default] [Ajp13] receive()

      Any ideas?

      Thanks,
      Alex