1 Reply Latest reply on May 15, 2002 6:20 PM by Jeff Doran

    Unable to bind any security domains

    Jeff Doran Newbie

      I'm running JBoss 2.4.3 and I'm unable to get any of my security domains to bind to JNDI. I've tried creating my own or just tried using the ones that come standard in auth.conf(simple or client-login). It doesn't matter what I specify for my <security-domain> in my jboss.xml file. When the 1st of my EJBs is deployed, I get the following JNDI error:

      "
      [Default] lookup securityDomain manager name: java:/jaas/simple
      [Container factory] org.jboss.ejb.DeploymentException: Could not find the Security Manager specified for this container, name= java:/jaas/simple , Cause:javax.naming.NameNotFoundException: java: not bound
      "

      I'm attempting to add security to a working configuration so I know that the general installation is correct. In addition, I have added the required jboss.xml and jboss-web.xml files, modified the auth.conf file, and checked that the JaasSecurityManagerService is running.

      Are there any known problems with security domains in 2.4.3?

      Thanks for your time.

      - Jeff D

        • 1. Re: Unable to bind any security domains - SOLVED
          Jeff Doran Newbie

          FYI, here's the solution to the mind numbing problem that I was having.

          It turns out that the <security-domain> in jboss.xml and jboss-web.xml is space sensitive. Any leading or trailing spaces between the angle brackets get included in the domain name. It will fail to match a domain in the auth.conf file, but what's worse is nowhere does it report what string it's looking for or what failed aside from a rather cryptic "not bound" message.

          Carefull with those spaces campers!