1 Reply Latest reply on Sep 11, 2002 12:06 PM by r_clegg1

    RMI+SSL on 3.0

    Rune Teigen Newbie

      I am trying to set up RMI+SSL for a sample application. From previous postings I have understood that my jboss-service.xml must be edited. The security part now looks like this:
      <!-- ==================================================================== -->
      <!-- Security -->
      <!-- ==================================================================== -->


      jboss.security:name=XMLLoginConfig


      login-config.xml


      <!-- JAAS security manager and realm mapping -->


      org.jboss.security.plugins.JaasSecurityDomain



      jboss.security:service=JaasSecurityManager



      some.keystore
      somepass


      I have also changed the configuration of the Standard Stateless SessionBean in jboss.xml. The jboss.xml for my deployment looks like this:


      <container-configurations>
      <container-configuration>
      <container-name>Standard Stateless SessionBean</container-name>
      <!-- Override the container socket factories -->
      <container-invoker-conf>
      true
      4445

      org.jboss.security.ssl.RMISSLClientSocketFactory


      org.jboss.security.ssl.RMISSLServerSocketFactory

      <ssl-domain>java:/jaas/RMI+SSL</ssl-domain>
      </container-invoker-conf>
      </container-configuration>
      </container-configurations>


      Starting the server works fine. Then I look-up the bean and call it from my client. This shouldn't work, since my client is not set up to run SSL. But it works, and I can see that the call comes in on port 4444 (where the JRMPInvoker listens?), not 4445 which I though I set up in the jboss.xml. Did I miss something? How do I get JBoss to route calls to port 4445, not 4444 in this case?

      thanks,
      rune