3 Replies Latest reply on Sep 11, 2002 10:24 AM by Mauricio De Diana

    No more Applets with JBOSS 30 ???

    FALOGIN Newbie

      dear forum,

      I have tried to use the appletExample from online-manual. It worked fine with JBOSS 2.4.0.
      With JBOSS 3.0 I got following Exception:
      java.security.AccessControlException: access denied (java.lang.RuntimePermission org.jboss.security.SecurityAssociation.getPrincipalInfo)

      at java.security.AccessControlContext.checkPermission(AccessControlContext.java:270)

      at java.security.AccessController.checkPermission(AccessController.java:401)

      at java.lang.SecurityManager.checkPermission(SecurityManager.java:542)

      at org.jboss.security.SecurityAssociation.getPrincipal(SecurityAssociation.java:109)

      at org.jboss.proxy.SecurityInterceptor.invoke(SecurityInterceptor.java:72)

      at org.jboss.proxy.ejb.HomeInterceptor.invoke(HomeInterceptor.java:185)

      at org.jboss.proxy.ClientContainer.invoke(ClientContainer.java:76)

      at $Proxy0.create(Unknown Source)

      at org.jboss.docs.appletclient.applet.AppletEjbCaller.callEjbButton_actionPerformed(AppletEjbCaller.java:87)

      What I have tried is to comment out the interceptor which is responsible for this exception ( SecurityInterceptor within standardjboss.xml )
      The result was a different exception thrown by the invocation Interceptor.
      ( By the way this was just for testing reasons, I do not think this guides to success )

      Is there anybody out there who has ported this AppletExample to JBOSS 30 or is it impossible to use applets anymore ?!