4 Replies Latest reply on Sep 26, 2002 4:50 PM by jayhowell

    principal=null problem only on AIX

      We have deployed this application on multiple sun boxes and everything works great. We have now deployed on an AIX box(version 4.33 running AIX JDK 1.3.1) and the same files don't appear to work. I have moved to another AIX box and have experienced the same behavior. It's really creepy, because this shouldn't happen, unless there is something wrong with the AIX JVM. Does anyone have JAAS working with AIX. Please look at the configuration files provided and tell me if you see anything wrong with them. They work fine on Solaris running 1.3.1 SDK from Sun. Any help would be greatly appreciated.

      Here is a snippet the error that I'm getting.
      2002-08-30 15:45:13,526 WARN [org.jboss.system.ServiceController] Ignoring request to destroy non-existant service: jboss.j2ee:service=EJB,jndiName=Orders
      2002-08-30 15:45:13,527 DEBUG [org.jboss.system.ServiceController] removing service: jboss.j2ee:service=EJB,jndiName=Orders
      2002-08-30 15:45:13,527 DEBUG [org.jboss.system.ServiceController] no need to remove jboss.j2ee:service=EJB,jndiName=Orders from server
      2002-08-30 15:45:13,527 INFO [org.jboss.ejb.EjbModule] Remove JSR-77 EJB Module: jboss.management.single:J2EEApplication=pharmacy.ear,J2EEServer=Single,j2eeType=EJBModule,name=pharmacy-ejb.jar
      2002-08-30 15:45:13,548 DEBUG [org.jboss.management.j2ee.J2EEManagedObject] preDeregister(), parent: jboss.management.single:J2EEServer=Single,j2eeType=J2EEApplication,name=pharmacy.ear
      2002-08-30 15:45:13,554 ERROR [org.jboss.ejb.EjbModule] Initialization failed
      java.lang.SecurityException: Invalid authentication attempt, principal=null
      at org.jboss.resource.connectionmanager.BaseConnectionManager2.getSubject(BaseConnectionManager2.java:662)
      at org.jboss.resource.connectionmanager.BaseConnectionManager2.allocateConnection(BaseConnectionManager2.java:503)
      at org.jboss.resource.adapter.jdbc.local.LocalDataSource.getConnection(LocalDataSource.java:101)
      at org.jboss.ejb.plugins.cmp.jdbc.SQLUtil.fixTableName(SQLUtil.java:38)
      at org.jboss.ejb.plugins.cmp.jdbc.bridge.JDBCEntityBridge.(JDBCEntityBridge.java:103)
      at org.jboss.ejb.plugins.cmp.jdbc.JDBCStoreManager.create(JDBCStoreManager.java:333)
      at org.jboss.ejb.plugins.CMPPersistenceManager.create(CMPPersistenceManager.java:155)
      at org.jboss.ejb.EntityContainer.create(EntityContainer.java:337)
      at org.jboss.ejb.Container.invoke(Container.java:789)
      at org.jboss.ejb.EntityContainer.invoke(EntityContainer.java:1055)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java(Compiled Code))

        • 1. Re: principal=null problem only on AIX

          Here are the Files that I used to configure the security

          • 2. Re: principal=null problem only on AIX

            I forgot to mention, this happens during deployment of an ear file. Jay:)

            • 3. Re: principal=null problem only on AIX

              I finally tracked the problem down. The problem is a classpath issue. I turned the trace on, the error message is only available through the trace, and I found that the error is thrown when trying to instantiate the org.jboss.resource.security.ConfiguredIdentityLoginModule class. This instantiation happens in the LoginContext class, which is part of the javax security api. The class can not be found in the classpath. I'm not sure why the classloader picks this up in Windows and Solaris, but It doesn't pick it up in AIX. I tried to put this class and a couple others in a classpath. I kept adding until I ran into problems with the other classes not being found by the classloader. I did get past the first error. I belive it has something to do with the URL classloader, but I'm just guessing. If anyone has run into this or has a work around, please sent it to me. I have been able to reproduce this problem on 3.0.0RC3, 3.0.1, and 3.0.2. If anyone knows how jboss handles classloaders and what is accessible through the classloaders, please tell me. Thanks, Jay:)

              • 4. Re: principal=null problem only on AIX

                Please see the following link for the solution to this problem.