4 Replies Latest reply on Oct 29, 2002 11:22 AM by John Snyder

    JBOSS + TOMCAT + SSL + PROBLEMS

    cfrostrun Newbie

      Hopefully somebody can tell me what i'm doing wrong here.. I'm relatively new to jboss & trying
      to get ssl running on port 8443 w/ a self signed certificate.

      Versions I'm running: jdk1.4
      redhat linux 7.*
      tomcat 4.0.1
      jboss 3.0.0

      Here's the script i'm running for my server.keystore

      keytool -genkey -alias tomcat -keyalg RSA \
      -dname 'CN=gellyphish, OU=Liquid Data Inc, O=Liquid Data Inc,
      L=XXX,S=XX, C=US' \
      -keypass changeit \
      -storepass changeit \
      -keystore server.keystore

      it created the file, and it's located in
      /usr/local/jboss/jboss.3.0.0/catalina/conf

      Here's the server.xml file
      <!-- Define an SSL HTTP/1.1 Connector on port 8443 -->







      I restart jboss ( has tomcat embedded ) and it doesn't start the
      services on that port. So where did I go wrong?

      TIA,

      Chris

        • 1. Re: JBOSS + TOMCAT + SSL + PROBLEMS
          cfrostrun Newbie

          Here's an update to where I'm at:

          I am able to run ssl on tomcat standalone just fine. But embedding it in jboss it's now throwing a null pointer exception.

          can somebody post their working tomcat-service.xml file that has ssl working? obviously the modification's I made to that is not configured correctly.

          Thanks,

          Chris

          • 2. Re: JBOSS + TOMCAT + SSL + PROBLEMS
            Brian Newbie

            Here is a sample tomcat4-service.xml file.
            Just open it and change the keystoreFile attribute value to the full path to you keystore file and put it in the deploy directory.

            Hope this helps if you are still having problems,
            Brian

            • 3. Re: JBOSS + TOMCAT + SSL + PROBLEMS
              John Snyder Newbie

              I'm new to JBoss and SSL. I have followed the advice and examples in this thread (thanks!), and have apparently made some progress. Specifically:
              1) No errors in starting JBoss;
              2) No errors in deploying an application (pc.ear);
              3) When I enter http://localhost:8443/pc in my browswer, I do not get a "page not found" error.

              However, what I do get when I enter http://localhost:8443/pc is just:  (i.e., encoded, undisplayable stuff).

              My question is, how do I access the servlets/JSP pages of my pc.ear application via the 8443 port, so that the transmissions from the client browser to the servlets/JSP pages are encrypted via SSL?

              I'm sure I'm missing something very fundamental here, but I don't know what it is -- I'm a first-timer.

              Thanks for any help.

              -- John

              • 4. Re: JBOSS + TOMCAT + SSL + PROBLEMS
                John Snyder Newbie

                I'm new to JBoss and SSL. I have followed the advice and examples in this thread (thanks!), and have apparently made some progress. Specifically:
                1) No errors in starting JBoss;
                2) No errors in deploying an application (pc.ear);
                3) When I enter http://localhost:8443/pc in my browswer, I do not get a "page not found" error.

                However, what I do get when I enter http://localhost:8443/pc is just:  (i.e., encoded, undisplayable stuff).

                My question is, how do I access the servlets/JSP pages of my pc.ear application via the 8443 port, so that the transmissions from the client browser to the servlets/JSP pages are encrypted via SSL?

                I'm sure I'm missing something very fundamental here, but I don't know what it is -- I'm a first-timer.

                Thanks for any help.

                -- John