3 Replies Latest reply on Jan 24, 2003 7:25 AM by Caroline Augustin

    JBoss-3.0.4 and postgres configuration

    Dominic Hanlan Newbie

      Hi,
      I am very new to JBoss and am having trouble configuring the DatabaseServerLoginModule using postgres. The problem is that JBoss running under a debugger does not find my dsJndiName.

      The story so far, with a clean install of 3.0.4 I have edited server/deploy/conf/login-conf.xml and added a new policy :-

      <application-policy name = "PostgresDbRealm">

      <login-module code = "org.jboss.security.auth.spi.DatabaseServerLoginModule" flag = "required">
      <module-option name = "dsJndiName">PostgresDS</module-option>

      .....

      </login-module>

      </application-policy>

      I have copied the example postgres-service.xml to the same conf directory


      <depends optional-attribute-name="ManagedConnectionFactoryName">
      <!--embedded mbean-->

      <!-- ========== Set the JndiName ======================= -->
      PostgresDS


      <config-property name="ConnectionURL" type="java.lang.String">jdbc:postgresql://192.168.40.3:5432/testDB</config-property>
      <config-property name="DriverClass" type="java.lang.String">org.postgresql.Driver</config-property>
      <!--set these only if you want only default logins, not through JAAS -->
      <config-property name="UserName" type="java.lang.String"></config-property>
      <config-property name="Password" type="java.lang.String"></config-property>




      I am having trouble tying up the jndi names. The dsJndiName comes through to the debugger but when the DatabaseServerLoginModule does a lookup on it, it fails. I have under the debugger tried, lookup combinations of java:/PostgresDS etc, but no luck .......

      I had this working, but no luck now ....

      Any help please ........

      Regards

      /Dominic