0 Replies Latest reply on Apr 17, 2003 4:09 PM by zoltron_rr

    Migration from 2.4.9 to 3.0.6 login problems.

    zoltron_rr Newbie

      Hi, I am new to Jboss and have been tasked with migrating to a newer version. Without too much detail, much of the system is new to me, meaning I built none of it. I have gotten a pool to work and can use a simple database connection to get records. However, I can not seem to get our login to work in 3.0.6 as it did in 2.4.9.

      I get the following error:
      --------------------------
      12:02:31,651 ERROR [LogonForm] Other exception.
      javax.ejb.FinderException: Find failed: java.sql.SQLException: Table not found: TBLUSER in statement [SELECT tblUser.U_KID FROM tblUser where U_UserName='username' AND U_Password='password']

      Here is the login-config.xml entry I have tried:
      ---------------------------------------------------
      <application-policy name="KietraDS">

      <login-module code = "org.jboss.resource.connectionmanager.JBossManagedConnectionPool" flag = "required">
      <module-option name ="managedConnectionFactoryName">jboss.jca:service=LocalTxPool,name=SybaseDB</module-option>
      </login-module>

      </application-policy>

      <application-policy name = "client-login">

      <login-module code = "org.jboss.security.ClientLoginModule"
      flag = "required">
      </login-module>

      </application-policy>

      Here is parts of the sybase-config.xml:
      ...
      <!--uncomment out this line if you are using the SybaseDSRealm above -->
      KietraDS
      ...


      KietraDS



      <!-- Sybase jConnect URL for the database.
      NOTE: The hostname and port of made up values. The optional
      database name is provided, as well as some additinal Driver
      parameters.
      -->
      <config-property name="ConnectionURL" type="java.lang.String">
      jdbc:sybase:Tds:machine:4100/database
      </config-property>
      <config-property name="DriverClass" type="java.lang.String">
      com.sybase.jdbc2.jdbc.SybDriver
      </config-property>
      <config-property name="UserName" type="java.lang.String">
      username
      </config-property>
      <config-property name="Password" type="java.lang.String">
      password
      </config-property>


      ...
      <depends optional-attribute-name="ManagedConnectionPool">
      <!--embedded mbean-->


      3
      10
      5000
      15
      ByContainer


      -------------------------------------
      I have tried all docs I could find on the web and looked through this form.

      I know I am not getting a DB connection, as we have watched the DB side for connections.

      I can set breakpoints in Eclipse and try to figure out more details, and have to a certain extent, but I am running out of guesses.

      My questions:
      ----------------
      What am I doing wrong?
      What else can I try?
      How can I find out what is REALLY going wrong?

      Thanx for reading all this.

      Jeff