0 Replies Latest reply on Aug 5, 2003 2:05 PM by erh

    Authenticating With Oracle

    erh Newbie

      I'm trying to authenticate users against an Oracle Database and having a weird problem.
      I'm using version 3.2.1 with tomcat 4.1.24.
      The oracle connection I'm using works perfectly from applications running inside JBoss, so that aspect it working. I have the exact same login and role table on a mysql database and using that to authenticate works perfectly as well. When I try to work against oracle, the Authenticator claims that the user is not in the table.
      Here are the relevant sections from the config:

      <application-policy name = "foo">

      <login-module code="org.jboss.security.auth.spi.DatabaseServerLoginModule" flag = "required">
      <module-option name = "dsJndiName">java:/oracle</module-option>
      <module-option name = "principalsQuery">select passwd from user where username=?</module-option>
      <module-option name = "rolesQuery">select role, 'Roles' from role where username=?</module-option>
      <module-option name = "debug">true</module-option>
      </login-module>

      </application-policy>


      <local-tx-datasource>
      java:/oracle
      <jndi-name>oracle</jndi-name>
      <connection-url>my_url</connection-url>
      <driver-class>oracle.jdbc.driver.OracleDriver</driver-class>
      <user-name>username</user-name>
      password
      <min-pool-size>1</min-pool-size>
      <max-pool-size>3</max-pool-size>
      <!-- <blocking-timeout-millis>5000</blocking-timeout-millis> -->
      <!-- <idle-timeout-minutes>15</idle-timeout-minutes> -->
      <exception-sorter-class-name>org.jboss.resource.adapter.jdbc.vendor.OracleExceptionSorter</exception-sorter-class-name>
      true
      </local-tx-datasource>

      Thanks for any help.