1 Reply Latest reply on Nov 6, 2003 5:38 PM by sys user

    problem in setting application-policy

    sys user Master

      Hi,

      I've a problem in setting up application policy.
      This is how i defined my security domain tag in ..\conf\web\WEB-INF\jboss-web.xml

      <security-domain>java:/jaas/myDomain</security-domain>

      And in ..server\default\conf\login-config.xml i defined my application tag as follows:

      <application-policy name = "myDomain">

      <login-module code = "org.jboss.security.auth.spi.DatabaseServerLoginModule"
      flag = "required">
      <module-option name = "dsJndiName">.....</module-option>
      <module-option name = "principalsQuery">..</module-option>
      <module-option name = "rolesQuery">...</module-option>
      <module-option name = "unauthenticatedIdentity">..</module-option>
      </login-module>

      </application-policy>
      <application-policy name = "other">

      <login-module code = "org.jboss.security.auth.spi.UsersRolesLoginModule"
      flag = "required" />

      </application-policy>


      The problem is it always refering to other application-policy name instead of myDomain. Where am doing wrong? If so, please give me step by step guidance. Thanks
      Pakodi

        • 1. Re: problem in setting application-policy
          sys user Master

          Also, I tried defining the <security-domain>java:/jaas/myDomain</security-domain> in jboss.xml. It did not work.

          Then I tried the following

          auth.conf has to be defined as
          myDomain{
          com.ociweb.auth.login.DatabaseLoginModule required
          dsJndiName=<blah..blah>
          principalsQuery=<blah..blah>
          rolesQuery=<blah..blah>
          ;
          // org.jboss.security.ClientLoginModule required
          // ;
          }

          It did not work either. I tried all possible combination and could not succeed. Dont tell any typos or what ever. All checked properly. I'm looking precise steps what to include and where . Please guide me. Thanks
          Pakodi