2 Replies Latest reply on Jul 1, 2004 7:24 AM by Pedro Salazar

    jmx-console authentication

    Pedro Salazar Newbie

      Greetings,

      I want to apply a basic authentication on jmx-console by just uncomment the web.xml/jboss-web.xml as referred in JBOSS FAQ.

      I did it, and it started to ask the login and password. However, even if a put a non existent user and/or a bad password, the authentication pass always OK!?

      I'm using jboss 3.2.4 with the standard configurations.

      What's wrong here?

      thanks,
      Pedro Salazar.

      #jmx-console-users.properties
      admin=admin
      
      #jmx-console-roles.properties
      admin=JBossAdmin
      
      #web.xml
       <login-config>
       <auth-method>BASIC</auth-method>
       <realm-name>JBoss JMX Console</realm-name>
       </login-config>
      
       <security-role>
       <role-name>JBossAdmin</role-name>
       </security-role>
      
      #jboss-web.xml
      <security-domain>java:/jaas/jmx-console</security-domain>
      
      #login-config.xml
      <application-policy name = "jmx-console">
       <authentication>
       <login-module code="org.jboss.security.auth.spi.UsersRolesLoginModule"
       flag = "required">
       <module-option name="usersProperties">jmx-console-users.properties</module-option>
       <module-option name="rolesProperties">jmx-console-roles.properties</module-option>
       </login-module>
       </authentication>
       </application-policy>
      


        • 1. Re: jmx-console authentication
          Jojo Paderes Newbie

          I did the same setup on my JBoss 3.2.4 installation on Fedora Core 1 Linux. The JMX Console authentication is working perfectly fine. I'm using Firefox and Konqueror browsers.

          That might be an erratic issue on JBoss 3.2.4 but so far I haven't encountered that on my installations.

          • 2. Re: jmx-console authentication
            Pedro Salazar Newbie

            I repeated the procedure on another machine and ... it worked OK as expected.

            I'll close the topic here because it must be a mistake somewhere that doesn't worth the hunt since now it's verified by you also as the correct procedure.

            And I'll reproduce the procedure in the machine with problem but with the new 3.2.5 release.

            Thanks,
            Pedro Salazar.