3 Replies Latest reply on Nov 3, 2004 5:30 PM by edkocol

    Application based security using evermind's RoleManager

    edkocol Newbie

      I have converted an application that was originally deployed to Oracle's J2EE AS. This application used evermind's RoleManager (included in the AS in oc4j.jar)

      The code to utilize the RoleManager is:

      com.evermind.security.RoleManager
      manager = (com.evermind.security.RoleManager)new InitialContext().lookup("java:comp/RoleManager");
      


      In running the application in Jboss this yields the following error:
      <<<< Root Cause Exception >>>>> javax.naming.NameNotFoundException: RoleManager not bound at org.jnp.server.NamingServer.getBinding(NamingServer.java:495)


      What I thought was necessary to solve this problem was to add the jar file containg the RoleManager class to the <jboss_home>/server/lib directory. After rebooting the machine, this did not solve the problem. I received the same error as above.

      Then I tried:
      ... InitialContext().lookup("java:comp/env/RoleManager");


      This too did not solve the problem. I recieved the same error as above.

      I would like to see this appliation work under Jboss before I consider investing the time in overhauling the security to JAAS.

      Can anyone help me with this?