1 Reply Latest reply on Nov 2, 2004 7:13 AM by schokoladenhase

    Disabling Client authentification...

    schokoladenhase Newbie

      Hi guys... im a bit frustrated...
      Im calling a session bean from an applet - works fine...
      Now i have to pass that rmi communication over ssl.

      I changed the jboss-service xml like this:
      <!-- The SSL domain setup -->




      gtc.keystore
      rmi+ssl



      443

      org.jboss.security.ssl.RMISSLClientSocketFactory


      org.jboss.security.ssl.RMISSLServerSocketFactory

      java:/jaas/RMI+SSL
      jboss.security:service=JaasSecurityDomain,domain=RMI+SSL


      It seems to work fine....

      But when trying to connect theres no connection.
      I sniffed my network and it tells me that it tries to connect to the ssl port and then the TLS protocol says unknown client cert....

      I would already be happy if i could disable client cert somewhere...

      Anyone helpful please :o9

        • 1. Re: Disabling Client authentification...
          schokoladenhase Newbie

          Damit.... the forum scred up the xml code.... is there still no edit-button ?
          well i tried changing the port from 443 to 8443 producing no tls package but still no connection....

          <mbean code="org.jboss.security.plugins.JaasSecurityDomain"
           name="jboss.security:service=JaasSecurityDomain,domain=RMI+SSL">
          <constructor>
          </constructor>
          <attribute name="KeyStoreURL">gtc.keystore</attribute>
          <attribute name="KeyStorePass">rmi+ssl</attribute>
          </mbean>
          <mbean code="org.jboss.invocation.jrmp.server.JRMPInvoker"
          name="jboss:service=invoker,type=jrmp">
          <attribute name="RMIObjectPort">443</attribute>
          <attribute name="RMIClientSocketFactory">
          org.jboss.security.ssl.RMISSLClientSocketFactory
          </attribute>
          <attribute name="RMIServerSocketFactory">
          org.jboss.security.ssl.RMISSLServerSocketFactory
          </attribute>
          <attribute name="SecurityDomain">java:/jaas/RMI+SSL</attribute>
          <depends>jboss.security:service=JaasSecurityDomain,domain=RMI+SSL</depends>
          </mbean>