0 Replies Latest reply on Dec 20, 2004 7:41 AM by hama

    JNDI over HTTP from weblogic

    hama Newbie

      Our system involves weblogic 8.1 sp3 and jboss server 3.2.3 communicating through JMS. We have included weblogic client jars (i.e. wlcipher.jar, wljmsclient.jar, and wlclient.jar) in jboss/server/default/lib and jbossall-client.jar in weblogic classpath. From jboss to weblogic, we use t3 and from weblogic to jboss, we use jnp. It works until we have NAT-firewalls between the two servers. We managed to get the jboss to talk to weblogic over t3. But not for jnp, we figured out it was because the default IL in jboss 3.2.3 was OIL, and it does not work across firewall. So we upgrade it to 3.2.6 and use httpIL instead. I used the code as outlined in the thread " "HTTP invoker and BASIC authentication" http://www.jboss.org/index.html?module=bb&op=viewtopic&t=31441
      and found that it works for standalone java client application but does not work if the code is executed in the weblogic server.

      FYI, we use mod_jk2 to forward /invoker/* /jboss-httpil/* from the apache to jboss.

      using the standalone client, the httpd access log is:

      127.0.0.1 - - [20/Dec/2004:18:53:29 +0800] "GET /invoker/JNDIFactory HTTP/1.1" 401 954
      127.0.0.1 - - [20/Dec/2004:18:53:29 +0800] "GET /invoker/JNDIFactory HTTP/1.1" 200 1384
      127.0.0.1 - - [20/Dec/2004:18:53:29 +0800] "POST /invoker/EJBInvokerServlet HTTP/1.1" 200 1451
      127.0.0.1 - - [20/Dec/2004:18:53:30 +0800] "POST /invoker/EJBInvokerServlet HTTP/1.1" 200 600
      127.0.0.1 - - [20/Dec/2004:18:53:30 +0800] "POST /jbossmq-httpil/HTTPServerILServlet HTTP/1.1" 200 120
      127.0.0.1 - - [20/Dec/2004:18:53:30 +0800] "POST /jbossmq-httpil/HTTPServerILServlet HTTP/1.1" 200 91
      127.0.0.1 - - [20/Dec/2004:18:53:30 +0800] "POST /jbossmq-httpil/HTTPServerILServlet HTTP/1.1" 200 93
      127.0.0.1 - - [20/Dec/2004:18:53:30 +0800] "POST /jbossmq-httpil/HTTPServerILServlet HTTP/1.1" 200 86
      127.0.0.1 - - [20/Dec/2004:18:53:30 +0800] "POST /jbossmq-httpil/HTTPServerILServlet HTTP/1.1" 200 86
      127.0.0.1 - - [20/Dec/2004:18:53:30 +0800] "POST /jbossmq-httpil/HTTPServerILServlet HTTP/1.1" 200 315
      127.0.0.1 - - [20/Dec/2004:18:53:30 +0800] "POST /jbossmq-httpil/HTTPServerILServlet HTTP/1.1" 200 113

      But the same code running in weblogic server, the access log is
      127.0.0.1 - - [20/Dec/2004:20:23:09 +0800] "GET /invoker/JNDIFactory HTTP/1.0" 401 954

      I have traced the program and checked that the LoginHandler() got called, with and the namecallback and passwordcallback, but it seems that it could not get the JNDIFactory successfully.

      Has anybody experienced this? And how to solve it.

      Thanks in advance,

      Regards,

      hama