3 Replies Latest reply on Feb 23, 2005 2:18 PM by Florian Fray

    LoginModule not invoked

    Florian Fray Newbie

      Hi guys!

      I'm really stuck with configuring a LoginModule for my web-app.
      I did the following:
      1. Created a Custom login module, JARed it and put it into server/all/lib
      2. Edited server/all/conf/login-config.xml and added an <application-policy>
      element (name = "webrealm") referencing my LoginModule.
      3. Added <security-constraint>, <login-config> and <security-role> to the web.xml. Any url is restricted and passed to a login.jsp.
      4. Added a configured jboss-web.xml to the web-inf directory
      5. Added a configured jboss.xml to the meta-inf directory
      6. Tried to access a JSP -> the login.jsp shows up -> i type in the user/pass -> the failure.jsp comes up.

      I set the debug-option to true for my LoginModule and checked the logs -> nothing!
      Now I've tried to reconfigure the "other" application-policy and checked the web-console -> same result -> nothing did happen.
      What am i doing wrong? Actually it seems that there is no invocation of any LoginModule at all!

      Please help me out!

      Greetz

      FF