1 Reply Latest reply on Apr 12, 2010 3:23 AM by ramesh shanmugam

    BEA Weblogic Portal 10.0 und Ajax4JSF

    Michael Post Newbie

      Hello,

      i want to marry Weblogic Portal 10.0 with Ajax4JSF.
      I use Ajax4JSF (jboss-ajax4jsf-1.1.1-bin.zip) of your website.
      I create a simple auto-suggestion-portlet and it works fine as jsf-app in the browser (IE and FF).

      But when i create a wlp-portlet (JSF-Portlet) it does not work.
      Maybe an bea weblogic portal problem, i do not know.

      What´s the behaviour?

      I call the jsf-file as .faces and it works fine.
      I create a jsf-portlet (currently not jsr168) i see all fine. When putting a character in the text-area, ajax should print the character on the site in the h:outputPanel. But the form seems to be completly send to the server and i got an complete new portlet.

      Why? Any ideas?

      Thanks for your help,

      Michael


      Following some code (without bean and faces-config.xml):

      --- test.jsp ---

      <%@ page language="java" contentType="text/html;charset=UTF-8"%>

      <%@ taglib uri="https://ajax4jsf.dev.java.net/ajax" prefix="a4j"%>
      <%@ taglib uri="http://java.sun.com/jsf/html" prefix="h" %>
      <%@ taglib uri="http://java.sun.com/jsf/core" prefix="f" %>

      <!-- Print current date -->
      <%= new java.util.Date().toLocaleString() %>

      <f:view>
      <h:form>
      <h:panelGrid columns="2">
      <h:outputText value="Type the Text:" />
      <h:inputText value="#{bean.text}">
      <a4j:support event="onkeyup" reRender="repeater" ajaxSingle="true" limitToList="repeater" disableDefault="true" />
      </h:inputText>
      </h:panelGrid>
      </h:form>

      <a4j:outputPanel id="outputpanel">
      <h:messages />
      <h:outputText value="AJAX-Text:" />
      <h:outputText id="repeater" value="#{bean.text}" />
      </a4j:outputPanel>
      <a4j:log level="ALL" popup="false" width="1000" height="100" />
      </f:view>

      --- test.jsp-File ---