2 Replies Latest reply on Jun 13, 2006 5:59 AM by Jörn Eyrich

    Securing the JMX invoker in JBossAS 3.2.6

    Jörn Eyrich Newbie

      I am trying to secure the detached jmx invoker on a JBoss AS 3.2.6 as described in the "SecureTheInvokers" wiki entry (http://wiki.jboss.org/wiki/Wiki.jsp?page=SecureTheInvokers).

      However, I get this error on startup (trace is from a 3.2.5 version, which shows the same problem):

      12:22:56,680 WARN [BasicMBeanRegistry] javax.management.MBeanRegistrationExcept
      ion: preRegister() failed: [ObjectName='jboss.jmx:type=adaptor,name=Invoker', Cl
      ass=org.jboss.jmx.connector.invoker.InvokerAdaptorService (org.jboss.jmx.connect
      or.invoker.InvokerAdaptorService@d75415)]
      12:22:56,680 INFO [InvokerAdaptorService] Registration is not done -> stop
      12:22:56,690 WARN [NestedThrowable] Duplicate throwable nesting of same base ty
      pe: class org.jboss.deployment.DeploymentException is assignable from: class org
      .jboss.deployment.DeploymentException
      12:22:56,690 ERROR [MainDeployer] could not create deployment: file:/C:/jboss-3.
      2.5/server/default/deploy/jmx-invoker-adaptor-server.sar/
      org.jboss.deployment.DeploymentException: create operation failed for package fi
      le:/C:/jboss-3.2.5/server/default/deploy/jmx-invoker-adaptor-server.sar/; - nest
      ed throwable: (org.jboss.deployment.DeploymentException: No PropertyDescriptor f
      or attribute:securityDomain; - nested throwable: (java.beans.IntrospectionExcept
      ion: No PropertyDescriptor for attribute:securityDomain))
      at org.jboss.deployment.SARDeployer.create(SARDeployer.java:227)
      at org.jboss.deployment.MainDeployer.create(MainDeployer.java:790)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:644)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:608)
      ...

      It works as advertised on 3.2.7 and 3.2.8SP1. The wiki entry says that it's upported from 3.2.4 on.

      We use a third-party component that the vendor has only "certified" for 3.2.6.

      I'm stumped, can anybody help me with this?

      Thanks in advance,
      Joern