3 Replies Latest reply on Oct 25, 2010 9:33 AM by johnsonb

    Problem starting service jboss:service=invoker,type=jrmp,soc

    Jason Nguyen Newbie

      Hi

      I'm using Jboss 4.0.5 for my work, and use the jrmp invoker to enable EJB over SSL. However, i have this problem when starting up the server. My configuration of the mbean is as follows:

      <mbean code="org.jboss.security.plugins.JaasSecurityDomain"
       name="jboss.security:service=JaasSecurityDomain,domain=RMI+SSL">
       <constructor>
       <arg type="java.lang.String" value="RMI+SSL"/>
       </constructor>
       <attribute name="KeyStoreURL">resource:server.keystore</attribute>
       <attribute name="KeyStorePass">123456</attribute>
       <attribute name="TrustStoreURL">resource:server.truststore</attribute>
       <attribute name="TrustStorePass">123456</attribute>
       <depends>jboss.security:service=JaasSecurityManager</depends>
       </mbean>
      
       <mbean code="org.jboss.invocation.jrmp.server.JRMPInvoker"
       name="jboss:service=invoker,type=jrmp,socketType=SSL">
       <attribute name="RMIObjectPort">14445</attribute>
       <attribute name="RMIClientSocketFactory">
       org.jboss.security.ssl.RMISSLClientSocketFactory</attribute>
       <attribute name="RMIServerSocketFactoryBean" attributeClass="org.jboss.security.ssl.RMISSLServerSocketFactory"
       serialDataType="javaBean">
       <property name="bindAddress">${jboss.bind.address}</property>
       <property name="securityDomain">java:/jaas/RMI+SSL</property>
       <property name="wantsClientAuth">true</property>
       <property name="needsClientAuth">true</property>
       </attribute>
       <depends>jboss.security:service=JaasSecurityManager</depends>
       <depends>jboss:service=TransactionManager</depends>
       <depends>jboss.security:service=JaasSecurityDomain,domain=RMI+SSL</depends>
      </mbean>
      


      the stack trace is: