2 Replies Latest reply on Sep 14, 2007 7:37 PM by Max Nokhrin

    JBoss SSL

    Max Nokhrin Newbie

      Hello everyone,

      I've been doing quite a thorough search on the Internet trying to figure out how to properly set up SSL with JBoss. I've come across various tutorials, some of which have been more helpful then others. In any case, at this stage, I followed these steps:

      1. Create a self-signed cert and import it into keystore.
      2. Set up the SSL config in server.xml

      I used the following command to create the cert:

      keytool -genkey -alias tc-ssl -keyalg RSA -keystore server.keystore -validity 3650

      And generally followed the instructions here:

      http://www.jboss.org/wiki/Wiki.jsp?page=SSLSetup

      However, I am getting a weird error when loading JBoss:

      SunX509 KeyManagerFactory not available

      From first thoughts, this seems that Jboss can't find the jsse.jar library, but I'm using IBM's JDK 1.5:

      java version "1.5.0"
      Java(TM) 2 Runtime Environment, Standard Edition (build pxi32dev-20070201 (SR4))
      IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 Linux x86-32 j9vmxi3223-20070201 (JIT enabled)
      J9VM - 20070131_11312_lHdSMR
      JIT - 20070109_1805ifx1_r8
      GC - 200701_09)
      JCL - 20070126

      Could this error be related to it being on IBM's JDK?

      Here's my server.xml snippet:

      <Connector port="8443" address="${jboss.bind.address}"
       maxThreads="100" strategy="ms" maxHttpHeaderSize="8192"
       emptySessionPath="true"
       scheme="https" secure="true" clientAuth="false"
       keystoreFile="${jboss.server.home.dir}/conf/server.keystore"
       keystorePass="amis1234" sslProtocol="TLS" />


      Any help would be greatly appreciated!
      Thanks!

        • 1. Re: JBoss SSL
          Deep Blue Li Newbie

          You have to put SSLEnabled="true"

          <Connector port="8443" address="${jboss.bind.address}"
           SSLEnabled="true"
           maxThreads="100" strategy="ms" maxHttpHeaderSize="8192"
           emptySessionPath="true"
           scheme="https" secure="true" clientAuth="false"
           keystoreFile="${jboss.server.home.dir}/conf/server.keystore"
           keystorePass="amis1234" sslProtocol="TLS" />


          Cheers,
          Deep Blue


          • 2. Re: JBoss SSL
            Max Nokhrin Newbie

            Thanks for the response. The error was actually in the fact that the server is running IBM's JDK rather than Sun's. Therefore, the fix was to add the following:

            algorithm="IbmX509"

            to the Connector tag

            :)