0 Replies Latest reply on Feb 18, 2008 7:21 AM by Nour-eddin DELERO

    openLDAP 2.3 integration in Jboss Portal 2.4

    Nour-eddin DELERO Newbie

      Hi,

      I have some difficulties to configure JBoss Portal 2.4 whith OpenLdap 2.3.
      this is my login-config.xml :


      <!DOCTYPE policy PUBLIC
       "-//JBoss//DTD JBOSS Security Config 3.0//EN"
       "http://www.jboss.org/j2ee/dtd/security_config.dtd">
      <policy>
       <!-- For the JCR CMS -->
       <application-policy name="cms">
       <authentication>
       <login-module code="org.apache.jackrabbit.core.security.SimpleLoginModule" flag="required"/>
       </authentication>
       </application-policy>
      
       <application-policy name="portal">
       <authentication>
      
       <login-module code="org.jboss.security.auth.spi.LdapExtLoginModule" flag="required" >
       <module-option name="java.naming.factory.initial">
       com.sun.jndi.ldap.LdapCtxFactory
       </module-option>
       <module-option name="java.naming.provider.url">
       ldap://10.210.1.3:389/
       </module-option>
       <module-option name="java.naming.security.authentication">
       simple
       </module-option>
       <module-option name="bindDN">cn=Manager,dc=axione,dc=fr</module-option>
       <module-option name="bindCredential">secret</module-option>
       <module-option name="baseCtxDN">ou=users,dc=axione,dc=fr</module-option>
       <module-option name="baseFilter">(uid={0})</module-option>
       <module-option name="rolesCtxDN">ou=roles,dc=axione,dc=fr</module-option>
       <module-option name="roleFilter">(member={1})</module-option>
       <module-option name="roleAttributeID">member</module-option>
       <module-option name="roleRecursion">-1</module-option>
       <module-option name="roleNameAttributeID">cn</module-option>
       <module-option name="roleAttributeIsDN">true</module-option>
       <module-option name="searchTimeLimit">5000</module-option>
       <module-option name="searchScope">SUBTREE_SCOPE</module-option>
       </login-module>
      
       </authentication>
       </application-policy>
      </policy>
      
      



      when i try to login into the portal I have the following error :
      "HTTP Status 403 - Access to the requested resource has been denied"
      I think there are some configurations to do in the web.xml, but i don't know how !!??

      thanks !