0 Replies Latest reply on Nov 21, 2001 9:43 AM by Pablo Casado

    mdb, queue, embedded tomcat and rmi port problem

    Pablo Casado Newbie

      Is this a bug?

      I'm using Jboss 2.4.0 with Tomcat 3.2.3 on Redhat Linux 7.1 and Blackdown jdk 1.3.1

      I created an mdb for a queue. I have another java app which runs on rmi/jnp port 1099 on my server so I run jboss on rmi port 1097. My bean deployed and worked fine on standalone jboss on both port 1099 (my workstation) and 1097 (my server).

      The bean also deployed and worked fine on jboss with embedded tomcat on port 1099 (my workstation). But when I deployed it to jboss plus tomcat on the server (rmi/jnp port 1097) it failed to deploy with the following error
      "JndiName not found:queue/myqueue"
      so I changed the port to 1097 on my workstation and it failed there, I ran jboss+tomcat on 1099 on the server and it worked.
      all my other beans (entity + session) work fine on jboss+tomcat+rmiport1097

      When changing port number I changed both jboss.jcml and jnp.properties.

      So it appears that the combination of an mdb, tomcat and rmi port change causes a problem.

      My apologies to this forum if this is not a messaging problem but it only occurs when trying to deploy a messaging bean.