3 Replies Latest reply on Aug 5, 2002 8:37 PM by Hiram Chirino

    Remote subscriber client not working in JBoss3

    Gang Cheng Newbie

      I have an application that used working fine in JBoss 2.4.4. It is a simple non-durable topic subscriber
      that runs on a client machine that is different from
      the JBoss server. After migrating to JBoss 3, it on longer
      works now. The publicher is inside the JBoss server JVM.

      Here is the log message on the server side:
      ....
      17:38:51,146 DEBUG [OILClientIL] ConnectionReceiverOILClient is connecting to: 192.168.121.226:4816
      17:39:16,173 DEBUG [SpySession] Session closing.

      And this is the log on the client side when connecting to the server:

      [DEBUG,SpyConnectionFactoryObjectFactory] Extracting SpyConnectionFactory from reference
      [DEBUG,SpyConnectionFactoryObjectFactory] The GenericConnectionFactory is: GenericConnectionFactory:[server=org.jboss.mq.il.oil.OILServerIL@125127,connectionProperties={OIL_TCPNODELAY_KEY=yes, PingPeriod=60000, OIL_PORT_KEY=8090, ClientILService=org.jboss.mq.il.oil.OILClientILService, OIL_ADDRESS_KEY=192.168.121.3}]
      [DEBUG,SpyDestinationObjectFactory] SpyDestinationObjectFactory->getObjectInstance()
      [DEBUG,Connection] Setting the clockDaemon's thread factory
      [DEBUG,GenericConnectionFactory] Handing out ClientIL: org.jboss.mq.il.oil.OILClientILService
      [DEBUG,OILClientILService] Waiting for the server to connect to me on port 4816

      There is no error/exception messages. The client does not get the message. I used a network sniffer and saw the message is sent from the server back to the client when a
      message is published to the topic. It is just the onMessage() never gets called by the JBossMQ code.

      I tried using OIL, UL, RMI connection factories, all do not work.

      The strange thing is that if I run the subscriber client program on the same machine (but different JVM) as the
      JBoss 3 server, it works fine. And if I make the subscriber a durable subscriber, all worked.

      I use JBoss (MX MicroKernel) [3.0.0 Date:200205311035]
      and JDK 1.3.0.1. Client OS is WinNT and the server is either
      Sun Solaris 8 or Win2K.

      I couldn't find anyone else having this problem. Maybe
      configuration issue ? It works fine in JBoss 2.4.4 and on the same machine.

      --- Gang Cheng