2 Replies Latest reply on Aug 16, 2002 4:24 AM by Peter Antman

    JMSProviderAdapterJNDI configuration

    Peter Kelley Newbie

      I'm trying to set up an MDB container that talks to a remote MQSeries box. In short the JMSProviderLoader MBean seems not to be honouring my QueueFactoryRef setting.

      I have the following in jboss-service.xml:

      <!-- The JMS provider loader -->

      MQSeriesJMSProvider

      org.jboss.jms.jndi.JBossMQProvider

      jms/mqseries/qcf
      jms/mqseries/qcf
      jboss:service=BindMQSeries


      (I have previously bound the connection factory using JNDI)

      But when I start the server I get :

      2002-08-16 15:27:21,381 DEBUG [org.jboss.system.ServiceCreator] About to create bean: jboss.mq:service=JMSProviderLoader,name=JBossMQProvider
      2002-08-16 15:27:21,381 DEBUG [org.jboss.system.ServiceCreator] code: org.jboss.jms.jndi.JMSProviderLoader
      2002-08-16 15:27:21,381 DEBUG [org.jboss.system.ServiceCreator] Created bean: jboss.mq:service=JMSProviderLoader,name=JBossMQProvider
      2002-08-16 15:27:21,381 DEBUG [org.jboss.system.ServiceConfigurator] ProviderName set to DefaultJMSProvider in jboss.mq:service=JMSProviderLoader,name=JBossMQProvider
      2002-08-16 15:27:21,391 DEBUG [org.jboss.system.ServiceConfigurator] ProviderAdapterClass set to org.jboss.jms.jndi.JBossMQProvider in jboss.mq:service=JMSProviderLoader,name=JBossMQProvider
      2002-08-16 15:27:21,391 DEBUG [org.jboss.system.ServiceConfigurator] QueueFactoryRef set to java:/XAConnectionFactory in jboss.mq:service=JMSProviderLoader,name=JBossMQProvider
      2002-08-16 15:27:21,391 DEBUG [org.jboss.system.ServiceConfigurator] TopicFactoryRef set to java:/XAConnectionFactory in jboss.mq:service=JMSProviderLoader,name=JBossMQProvider

      Which seems to indicate that the JMSProviderLoader is not honouring my QueueFactoryRef setting. This of course leads to problems later on when I try and use an MQSeries queue because the default connection factory won't work with MQSeries queues.

      Is this a bug ?