1 Reply Latest reply on May 18, 2003 6:10 AM by mars73

    JBoss using MQSeries as JMS provider

    Mark Newbie

      I am having problems getting JMSAdmin to work. I installed MQSeries 5.2, JBoss 3.0.6, and ma88 support pack on win2k. I run a batch file to setup the paths before I run JMSAdmin.bat. Here is the contents of the batch file:

      @echo off
      set MQ_JAVA_INSTALL_PATH=C:\WSMQ\Java

      @rem Java runtime
      set JAVA_HOME=C:\j2sdk1.4.0\bin

      @rem J2EE
      @rem set J2EE_HOME=C:\jboss-3.0.6_tomcat-4.1.18\server\default
      set J2EE_HOME=C:\j2sdkee1.3.1

      @rem MQ JMS
      set MQ=%MQ%;%MQ_JAVA_INSTALL_PATH%\lib
      set MQ=%MQ%;%MQ_JAVA_INSTALL_PATH%\lib\com.ibm.mq.jar
      set MQ=%MQ%;%MQ_JAVA_INSTALL_PATH%\lib\com.ibm.mqjms.jar
      set MQ=%MQ%;%MQ_JAVA_INSTALL_PATH%\lib\connector.jar

      set CLASSPATH=%MQ%;%CLASSPATH%;%J2EE_HOME%\lib\j2ee.jar
      set PATH=%JAVA_HOME%\bin;%J2EE_HOME%\bin;%MQ_JAVA_INSTALL_PATH%\lib;%PATH%;

      I modified the JMSAdmin.config file to the following setup:
      INITIAL_CONTEXT_FACTORY=org.jnp.interfaces.NamingContextFactory
      PROVIDER_URL=jnp://localhost/

      When I run JMSAdmin.bat I get the following error:
      "JNDI initialisation failed, please check your JNDI settings and service"

      I do have an instance of JBoss started.

      Any ideas what is wrong with my setup? Or should I be setting the jms factory and queue differently?

      Thanks,
      Mark