4 Replies Latest reply on May 31, 2003 1:04 AM by alex22

    JBoss and SwiftMQ

    alex22 Newbie

      Hello,

      Hope this is the correct forum to post to.

      Currently, i trying to use integrated swiftMQ into Jboss. I have followed the instruction published in the SwiftSoftware.com and everything seems to be worked fine.

      However, when i connect to JBoss using the swiftMQ explorer, i got the following errors.

      2003-05-27 18:39:07,867 INFO [org.jboss.system.server.Server] JBoss (MX MicroKernel) [3.0.4 Date:200211021607] Started in 0m:24s:703ms
      2003-05-27 18:39:12,820 ERROR [STDERR] java.lang.LinkageError: Class com/swiftmq/impl/jms/standard/SwiftletContext violates loader constraints
      2003-05-27 18:39:12,820 ERROR [STDERR] at java.lang.ClassLoader.defineClass0(Native Method)
      2003-05-27 18:39:12,836 ERROR [STDERR] at java.lang.ClassLoader.defineClass(ClassLoader.java:502)
      2003-05-27 18:39:12,836 ERROR [STDERR] at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
      2003-05-27 18:39:12,836 ERROR [STDERR] at java.net.URLClassLoader.defineClass(URLClassLoader.java:250)
      2003-05-27 18:39:12,836 ERROR [STDERR] at java.net.URLClassLoader.access$100(URLClassLoader.java:54)
      2003-05-27 18:39:12,836 ERROR [STDERR] at java.net.URLClassLoader$1.run(URLClassLoader.java:193)
      2003-05-27 18:39:12,836 ERROR [STDERR] at java.security.AccessController.doPrivileged(Native Method)
      2003-05-27 18:39:12,836 ERROR [STDERR] at java.net.URLClassLoader.findClass(URLClassLoader.java:186)
      2003-05-27 18:39:12,836 ERROR [STDERR] at org.jboss.mx.loading.UnifiedClassLoader.findClass(UnifiedClassLoader.java:239)
      2003-05-27 18:39:12,836 ERROR [STDERR] at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
      2003-05-27 18:39:12,851 ERROR [STDERR] at org.jboss.mx.loading.UnifiedClassLoader.loadClassLocally(UnifiedClassLoader.java:247)
      2003-05-27 18:39:12,851 ERROR [STDERR] at org.jboss.mx.loading.UnifiedLoaderRepository3.loadClassFromClassLoader(UnifiedLoaderRepository3.java:208)
      2003-05-27 18:39:12,851 ERROR [STDERR] at org.jboss.mx.loading.LoadMgr.beginLoadTask(LoadMgr.java:119)
      2003-05-27 18:39:12,851 ERROR [STDERR] at org.jboss.mx.loading.UnifiedClassLoader3.loadClass(UnifiedClassLoader3.java:140)
      2003-05-27 18:39:12,851 ERROR [STDERR] at java.lang.ClassLoader.loadClass(ClassLoader.java:255)
      2003-05-27 18:39:12,851 ERROR [STDERR] at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315)
      2003-05-27 18:39:12,851 ERROR [STDERR] at com.swiftmq.impl.jms.standard.VersionSelector.(Unknown Source)
      2003-05-27 18:39:12,851 ERROR [STDERR] at com.swiftmq.impl.jms.standard.l.connected(Unknown Source)
      2003-05-27 18:39:12,851 ERROR [STDERR] at com.swiftmq.impl.net.standard.scheduler.b.run(Unknown Source)
      2003-05-27 18:39:12,867 ERROR [STDERR] at com.swiftmq.impl.threadpool.standard.PoolThread.run(Unknown Source)

      Can anyone please help me. I have no idea what is the problem?

      Thank You


        • 1. Re: JBoss and SwiftMQ
          Adrian Brock Master

          You have duplicate classes somewhere.

          If you can't find them,
          try upgrading to the latest version of jboss,
          we've changed the classloader so that it
          ignores duplicate classes.

          Regards,
          Adrian

          • 2. Re: JBoss and SwiftMQ
            alex22 Newbie

            Thanks,

            But i have tried on Jboss 3.2.1 and still getting the errors.


            Any further advices you could give me is appreciated.





            • 3. Re: JBoss and SwiftMQ
              Adrian Brock Master

              Didn't you get an error message about duplicate
              classes?

              If you use http://localhost:8080/jmx-console
              and look for the loader repository mbean
              in JMImplementation you should be able
              to get information about where classes
              are deployed.

              Regards,
              Adrian

              • 4. Re: JBoss and SwiftMQ
                alex22 Newbie

                Thanks Adrian,

                Forgive my double postings.

                Finally, i have figured out where the problem lies to.

                Since i pretty new to SwiftMQ and Jboss itself, it took me a while to figure out SwiftMQ configuration. Once i understand the configuration file of the swiftMQ, things become easier.

                Basically, what i have did is.

                1) Download the JMS XA/ASF Swiftlet package.
                2) Replace the JMS Kernel Swiftlet and config file with that provided by the above.
                3) Start the JBoss and everything seems to work fine.