8 Replies Latest reply on Apr 17, 2008 11:40 AM by Nick Belaevski

    reRender issue: characters escaped

    Tom Barry Newbie

      I originally raised this issue in the seam forum (http://www.seamframework.org/Community/RerenderProblemWithFparamInSlink#comment16607). I didn't do a very good job describing the problem, and I think it's an Ajax4JSF issue, not a seam one.

      In a nutshell, the <s:link> seam component does not render properly after an Ajax4JSF reRender event when it contains more than one <f:param> tag. The ampersand character is always escaped- '&' is rendered as '&-#-3-8' (minus the dashes, of course).

      Here's a simple way to reproduce the problem. Take the seam-booking app from the seam examples and edit view/main.xhtml. Add a couple of arbitrary parameter tags to the 'View Hotel' link (at or near line 68):

      <s:link id="viewHotel" value="View Hotel" action="#{hotelBooking.selectHotel(hot)}">
       <f:param name="key1" value="1"/>
       <f:param name="key2" value="2"/>
      </s:link>


      Deploy the app, login, click the 'Find Hotels' button, and look at the 'View Hotel' links.

      I tried upgrading to the latest version of JSF RI and tried using RichFaces 3.1.3, 3.1.4 and 3.2- all with the same result.

      This is a show-stopper for me, so any help is greatly appreciated.