6 Replies Latest reply on Dec 4, 2003 6:08 PM by kprindia

    DefaultJMSProvider error?

    gooperaus Newbie

      After I put one MDB jar file under the deploy directory of jboss3.2.1, it has the following error:



      2003-07-29 15:29:20,203 ERROR [org.jboss.ejb.plugins.jms.JMSContainerInvoker] Starting failed
      javax.naming.NameNotFoundException: DefaultJMSProvider not bound

      what's the meaning?

        • 1. Re: DefaultJMSProvider error?
          gooperaus Newbie

          Is this a bug in jboss?

          The previous error happened when
          1. copy the MDB to deploy directory
          2. start the jboss

          but when I change the order to :
          1. start the jboss
          2. copy the MDB to deploy directory

          it works!

          • 2. Re: DefaultJMSProvider error?
            gooperaus Newbie

            When I deployed a durable MDB, I got the following error, why?

            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

            16:02:02,531 WARN [JMSContainerInvoker] JMS provider failure detected:
            javax.jms.IllegalStateException: The connection has already a clientID
            at org.jboss.mq.Connection.setClientID(Connection.java:339)
            at org.jboss.ejb.plugins.jms.JMSContainerInvoker.innerCreate(JMSContaine
            rInvoker.java:466)

            • 3. Re: DefaultJMSProvider error?
              youfshy Newbie

              Maybe someone has answered this question, try move(not copy) all files(not include its' subdirectory) in the deploy/jms directory into the deploy directory, and restart jboss.

              Good Lucky.
              Youfshy

              • 4. Re: DefaultJMSProvider error?
                Duncan Newbie

                Did you ever figure this out?

                I am having this problem and it renders MDBs useless. I can not deploy my MDBs under JBoss 3.2.1?

                It looks like the Message Drive Container is starting before JMS is available?

                • 5. Re: DefaultJMSProvider error?
                  Duncan Newbie

                  Did you ever figure this out?

                  I am having this problem and it renders MDBs useless. I can not deploy my MDBs under JBoss 3.2.1?

                  It looks like the Message Drive Container is starting before JMS is available?

                  • 6. Re: DefaultJMSProvider error?
                    kprindia Newbie

                    I found another alternative to do this. Specify the dependency on DefaultJMSProvider in jboss.xml packaged with a message driven bean. If it doesn't exist, create one to specify the dependency.
                    Dependency can be specified in jboss.xml using element.
                    This is present in 3.2.1 onwards. Look into jboss_3_2.dtd to know more about depends element.
                    The value to specify for depends is
                    jboss.mq:service=JMSProviderLoader,name=JBossMQProvider
                    It worked for me and hope it works for others too.
                    JBoss will anyway throw some exception while starting, but that exception just gives indication.
                    Later when DefaultJMSProvider is started, jboss starts all the dependent components on the DefaultJMSProvider. At that time it will again start the message driven bean.

                    In general any dependency can be specified using this element in jboss.xml but it has to be figured out on a case by case basis.
                    I got this info from a previous question on this news group. Even MDB dependency on any EJBs can be specified here.
                    Info on this is present in this forum under the question
                    NullPointerException getting ejb-ref on MDB startup