2 Replies Latest reply on Aug 21, 2003 11:27 AM by Adrian Brock

    how to increase MDB Max Message ?

    favoriti Newbie

      Hi,

      Can someone tell me how to increase the Max Messages treated by MDB, or how to increase the MDB pool size.

      My problem is that with Jboss 3.2 i can't get more than 15 MDB instances (default value ?) listening to a jms queue.
      As 1 MDB instance proceed only 1 message at time, my system performances are low.

      I've tried to set the and in jboss.xml, with no success.


      Here is my jboss.xml conf:


      <enterprise-beans>
      <message-driven>
      <ejb-name>MDB1</ejb-name>
      <destination-jndi-name>
      queue/EntreeJMSQueue
      </destination-jndi-name>
      <configuration-name>
      config_mdb
      </configuration-name>
      </message-driven>
      </enterprise-beans>

      <container-configurations>
      <container-configuration>
      <container-name>
      config_mdb
      </container-name>
      <call-logging>false</call-logging>
      <invoker-proxy-binding-name>
      message-driven-bean
      </invoker-proxy-binding-name>
      <container-interceptors>
      org.jboss.ejb.plugins.ProxyFactoryFinderInterceptor


      <!-- CMT -->

      org.jboss.ejb.plugins.TxInterceptorCMT

      org.jboss.ejb.plugins.MetricsInterceptor

      org.jboss.ejb.plugins.MessageDrivenInstanceInterceptor


      <!-- BMT -->

      org.jboss.ejb.plugins.MessageDrivenInstanceInterceptor

      org.jboss.ejb.plugins.MessageDrivenTxInterceptorBMT

      org.jboss.ejb.plugins.MetricsInterceptor



      org.jboss.resource.connectionmanager.CachedConnectionInterceptor


      </container-interceptors>
      <instance-pool>
      org.jboss.ejb.plugins.MessageDrivenInstancePool
      </instance-pool>

      <container-invoker-conf> 100
      100
      </container-invoker-conf>

      <container-pool-conf>
      100
      </container-pool-conf>
      </container-configuration>
      </container-configurations>




        • 1. Re: how to increase MDB Max Message ?
          cbrautigam Newbie

          I adjusted my pool size by modifying the default\conf\standardjboss.xml file

          Here is a sample entry for the message beans...
          <invoker-proxy-binding>
          message-driven-bean
          <invoker-mbean>default</invoker-mbean>
          <proxy-factory>org.jboss.ejb.plugins.jms.JMSContainerInvoker</proxy-factory>
          <proxy-factory-config>
          DefaultJMSProvider
          StdJMSPool
          50
          1

          10

          queue/DLQ
          10
          0


          </proxy-factory-config>
          </invoker-proxy-binding>

          The default setting was in fact 15. I bumped mine up to 50 and when I sent over about 60 messages in a tight loop from the producer, JBoss just locked up on me and started throwing timed out errors...So I'm trying to see what other things I need to adjust. Hope this helps though!

          • 2. Re: how to increase MDB Max Message ?
            Adrian Brock Master

            This is the ServerSessionPool.

            In 3.2 the config is on the invoker-proxy-binding, see
            standardjboss.xml

            Regards,
            Adrian