2 Replies Latest reply on May 21, 2008 3:19 AM by Alireza Salimi

    AjaxStateManager class version on JDK 1.4

    Alireza Salimi Newbie

      Hi

      Our company is working on a research for comparing different Ajax
      technologies for its web tier. Today I've downloaded 'richfaces-ui-3.2.0.SR1'.
      Although it is stated in its reference document that it is compatible
      with JDK 1.4 and Tomcat 4.1, but when a simple project is deployed in
      Tomcat 4.1, the following exception is being shown in terminal:

      2008-05-19 14:25:14 StandardContext[/richtest]: Exception sending context initialized event to listener in stance of class org.apache.myfaces.webapp.StartupServletContextListener
      java.lang.UnsupportedClassVersionError: org/ajax4jsf/application/AjaxStateManager (Unsupported major.minor version 49.0)
      


      Any ideas about this error?

      I was not sure if I should send this post to this forum, by the way, since
      it seems that it is related to Ajax4Jsf, I decided to post it here.